summaryrefslogtreecommitdiff
path: root/dev-ros/imu_transformer/imu_transformer-0.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/imu_transformer/imu_transformer-0.3.0.ebuild')
-rw-r--r--dev-ros/imu_transformer/imu_transformer-0.3.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ros/imu_transformer/imu_transformer-0.3.0.ebuild b/dev-ros/imu_transformer/imu_transformer-0.3.0.ebuild
new file mode 100644
index 000000000000..bd9fa0e9bf63
--- /dev/null
+++ b/dev-ros/imu_transformer/imu_transformer-0.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-perception/imu_pipeline"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Transforms sensor_msgs::Imu data from one frame into another"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/message_filters
+ dev-ros/nodelet
+ dev-libs/console_bridge:=
+ dev-ros/roscpp
+ dev-ros/roslaunch
+ dev-ros/tf
+ dev-ros/tf2
+ dev-ros/tf2_ros
+ dev-ros/topic_tools
+ dev-ros/tf2_sensor_msgs
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}