summaryrefslogtreecommitdiff
path: root/dev-ros/interactive_marker_tutorials/interactive_marker_tutorials-0.11.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/interactive_marker_tutorials/interactive_marker_tutorials-0.11.0.ebuild')
-rw-r--r--dev-ros/interactive_marker_tutorials/interactive_marker_tutorials-0.11.0.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/dev-ros/interactive_marker_tutorials/interactive_marker_tutorials-0.11.0.ebuild b/dev-ros/interactive_marker_tutorials/interactive_marker_tutorials-0.11.0.ebuild
index 19ee9324c9d7..a4442a8e777d 100644
--- a/dev-ros/interactive_marker_tutorials/interactive_marker_tutorials-0.11.0.ebuild
+++ b/dev-ros/interactive_marker_tutorials/interactive_marker_tutorials-0.11.0.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-visualization/visualization_tutorials"
KEYWORDS="~amd64"
ROS_SUBDIR=${PN}
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -17,10 +16,12 @@ IUSE=""
RDEPEND="
dev-ros/roscpp
dev-ros/interactive_markers
- dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/tf[${PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/tf[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
dev-libs/boost:=
"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"