summaryrefslogtreecommitdiff
path: root/dev-ros/map_server/map_server-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/map_server/map_server-9999.ebuild')
-rw-r--r--dev-ros/map_server/map_server-9999.ebuild22
1 files changed, 17 insertions, 5 deletions
diff --git a/dev-ros/map_server/map_server-9999.ebuild b/dev-ros/map_server/map_server-9999.ebuild
index 429845481287..01d98e8306e2 100644
--- a/dev-ros/map_server/map_server-9999.ebuild
+++ b/dev-ros/map_server/map_server-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-planning/navigation"
ROS_SUBDIR=${PN}
KEYWORDS="~amd64 ~arm"
@@ -15,14 +15,26 @@ IUSE=""
RDEPEND="
sci-physics/bullet:=
- dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/roscpp
- media-libs/sdl-image
+ media-libs/sdl-image[png]
dev-ros/tf2
>=dev-cpp/yaml-cpp-0.5:=
dev-libs/boost:=
"
DEPEND="${RDEPEND}
- test? ( dev-ros/rostest dev-ros/rospy dev-ros/rosunit )
+ test? (
+ dev-ros/rostest
+ dev-ros/rospy
+ dev-ros/rosunit
+ dev-cpp/gtest
+ )
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+BDEPEND="
virtual/pkgconfig"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}