summaryrefslogtreecommitdiff
path: root/dev-ros/message_to_tf/message_to_tf-0.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/message_to_tf/message_to_tf-0.3.0.ebuild')
-rw-r--r--dev-ros/message_to_tf/message_to_tf-0.3.0.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-ros/message_to_tf/message_to_tf-0.3.0.ebuild b/dev-ros/message_to_tf/message_to_tf-0.3.0.ebuild
index 5b2da944b6a4..1c31dc9a9a66 100644
--- a/dev-ros/message_to_tf/message_to_tf-0.3.0.ebuild
+++ b/dev-ros/message_to_tf/message_to_tf-0.3.0.ebuild
@@ -1,24 +1,25 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
inherit ros-catkin
-DESCRIPTION="Translates pose information from different kind of common_msgs message types to tf"
+DESCRIPTION="Translates pose information from different kind of common message types to tf"
LICENSE="BSD"
SLOT="0"
IUSE=""
RDEPEND="
dev-ros/tf
+ dev-ros/topic_tools
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/topic_tools
- dev-libs/boost:=
"
-DEPEND="${RDEPEND}"