summaryrefslogtreecommitdiff
path: root/dev-ros/rosnode/rosnode-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosnode/rosnode-9999.ebuild')
-rw-r--r--dev-ros/rosnode/rosnode-9999.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/dev-ros/rosnode/rosnode-9999.ebuild b/dev-ros/rosnode/rosnode-9999.ebuild
index 032e59ae3c1e..6ac973a5e5a1 100644
--- a/dev-ros/rosnode/rosnode-9999.ebuild
+++ b/dev-ros/rosnode/rosnode-9999.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/ros_comm"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=tools/${PN}
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -16,9 +15,13 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-ros/genmsg[${PYTHON_USEDEP}]
- dev-python/rospkg[${PYTHON_USEDEP}]
- dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/genmsg[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostopic[${PYTHON_SINGLE_USEDEP}]
"
DEPEND="${RDEPEND}
- test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ )"