summaryrefslogtreecommitdiff
path: root/dev-ros/rospy/rospy-1.13.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rospy/rospy-1.13.5.ebuild')
-rw-r--r--dev-ros/rospy/rospy-1.13.5.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-ros/rospy/rospy-1.13.5.ebuild b/dev-ros/rospy/rospy-1.13.5.ebuild
deleted file mode 100644
index 343c2a3a7d1f..000000000000
--- a/dev-ros/rospy/rospy-1.13.5.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-ROS_REPO_URI="https://github.com/ros/ros_comm"
-KEYWORDS="~amd64 ~arm"
-CATKIN_HAS_MESSAGES=yes
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
-ROS_SUBDIR=clients/${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="Python client library for ROS"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/roslib[${PYTHON_USEDEP}]
- dev-ros/rosgraph[${PYTHON_USEDEP}]
- dev-python/rospkg[${PYTHON_USEDEP}]
- dev-ros/roscpp[${PYTHON_USEDEP}]
- dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}"
-
-src_install() {
- ros-catkin_src_install
- # Other tests need these nodes
- exeinto /usr/share/${PN}
- doexe test_nodes/*
-}