summaryrefslogtreecommitdiff
path: root/dev-ros/smach_ros/smach_ros-2.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/smach_ros/smach_ros-2.5.0.ebuild')
-rw-r--r--dev-ros/smach_ros/smach_ros-2.5.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/smach_ros/smach_ros-2.5.0.ebuild b/dev-ros/smach_ros/smach_ros-2.5.0.ebuild
new file mode 100644
index 000000000000..ad6de87c90ae
--- /dev/null
+++ b/dev-ros/smach_ros/smach_ros-2.5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/executive_smach"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Extensions for the SMACH library to integrate it tightly with ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostopic[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/actionlib[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/smach[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/smach_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}