summaryrefslogtreecommitdiff
path: root/dev-ros/test_rosservice/test_rosservice-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/test_rosservice/test_rosservice-9999.ebuild')
-rw-r--r--dev-ros/test_rosservice/test_rosservice-9999.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/dev-ros/test_rosservice/test_rosservice-9999.ebuild b/dev-ros/test_rosservice/test_rosservice-9999.ebuild
index e11c3e08c1d1..7f51764ff341 100644
--- a/dev-ros/test_rosservice/test_rosservice-9999.ebuild
+++ b/dev-ros/test_rosservice/test_rosservice-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/ros_comm"
KEYWORDS="~amd64 ~arm"
@@ -9,8 +9,6 @@ ROS_SUBDIR=test/${PN}
CATKIN_HAS_MESSAGES=yes
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
-PYTHON_COMPAT=( python2_7 )
-
inherit ros-catkin
DESCRIPTION="Unit tests for rospy"
@@ -20,11 +18,12 @@ IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}
- dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
test? (
- dev-ros/test_rosmaster[${PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-ros/rostest[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
+ dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosservice[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
)"