summaryrefslogtreecommitdiff
path: root/dev-ruby/actiontext
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/actiontext')
-rw-r--r--dev-ruby/actiontext/Manifest1
-rw-r--r--dev-ruby/actiontext/actiontext-6.1.7.4-r1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-ruby/actiontext/Manifest b/dev-ruby/actiontext/Manifest
index a20aaafff541..36925741e15a 100644
--- a/dev-ruby/actiontext/Manifest
+++ b/dev-ruby/actiontext/Manifest
@@ -7,6 +7,7 @@ DIST rails-7.0.6.tgz 11090672 BLAKE2B 87d3c1d37f0af4c6a9590d9e38cf1674c59b01b1e1
EBUILD actiontext-6.0.6.1.ebuild 1762 BLAKE2B 8776f80d2662396e92750b5ac0f28a3533f09be9f5e1f0d2678ddc8d448b631324cc0eca8eeaa265f8c11555ae22331eefb396fb5fb8a21f65f8b4dae66c9a0f SHA512 71e0e4a1b2409cc9bc7f25c6b9df8c0018371604ef7f024a9003b999df259df78e9dc8eadc3d4ce8b014356e4589dfebe9cd755be87a6c35470759804d0984a9
EBUILD actiontext-6.1.7.2.ebuild 1792 BLAKE2B 138912b1271f54e86e4c69d031a4f28af012dc31c473480f496b391bb222eb45da881c45cef375e20792cf0336a3cadb29ac8ac345606b6000835d32e477fa19 SHA512 1774282c9f09ad0c356a302acc167fdd93b219089edb66b4b50a8a603e1b0cd609c1f0fe156adb38058b8e5e4988a20544e4802c68b1a87f8e2213e658dfdedb
EBUILD actiontext-6.1.7.3.ebuild 1810 BLAKE2B 10d8fa4f3590e03b3d7147cf1162c5fdc11d1a1ec444fcfb1a1f36a68b5fe34231982aeb1887941e08681a92976534dbb78704283c5a63bde5b437a3d4b94fee SHA512 07a66edff485c59c09697cbab1b1b633cb26361f4647b21bc504c6b3b811df0c5f28f994e6b8e59f07ebce838a9245b03c7193d9d8fdb826f2aef5f467176f97
+EBUILD actiontext-6.1.7.4-r1.ebuild 1876 BLAKE2B 737602ad29a18fee057e35efadee12c7ab66b17fda11f8399e6038ce1bb29cf06ceb872ec7a4f713dbbd94de95f30de745115749631fae2cb7e491307fcead6b SHA512 62c1a930240ffd2450b1b7de11dacfcb5cae8b145c01014a5c4efdac3f95ad1ccfaccc996a9845ec22ba52c6d4b955ee2c809f594a0ed1765f5041681a39aacb
EBUILD actiontext-6.1.7.4.ebuild 1846 BLAKE2B 47f611de02468fd857248a77777878c154236523d684febefe557823335142986f80adec0cc05448d498b6d5f2acf63e6297f9d5e49bf48bdf77eb73e7171cca SHA512 92f9052aab58679fbb42166e9939941ac35ddd87b189fdcb7620085e6b3953fac50c6f035ebccf50b710db876e471789015dd23506e3036f656843d7f6772527
EBUILD actiontext-7.0.5.1.ebuild 1946 BLAKE2B 245bc604ac5a5abe92f57a40b60551f6f67b5bb1c3a60163337fdc6fe52a9f64a5f9c469ec700f0a378f28d1581e36f947baa8bbc166b74d1936e24cf595af0c SHA512 a81edab5ef1d61949ad659f1800f4ccee6b70a386e751a18cd0b8106d9276d87944b9d8fc9931499be0fca20c1c190c7689b9065b223884b1e52541b9e49a865
EBUILD actiontext-7.0.6.ebuild 1946 BLAKE2B 245bc604ac5a5abe92f57a40b60551f6f67b5bb1c3a60163337fdc6fe52a9f64a5f9c469ec700f0a378f28d1581e36f947baa8bbc166b74d1936e24cf595af0c SHA512 a81edab5ef1d61949ad659f1800f4ccee6b70a386e751a18cd0b8106d9276d87944b9d8fc9931499be0fca20c1c190c7689b9065b223884b1e52541b9e49a865
diff --git a/dev-ruby/actiontext/actiontext-6.1.7.4-r1.ebuild b/dev-ruby/actiontext/actiontext-6.1.7.4-r1.ebuild
new file mode 100644
index 000000000000..454fdb684f2c
--- /dev/null
+++ b/dev-ruby/actiontext/actiontext-6.1.7.4-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="actiontext.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRAINSTALL="app db package.json"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Edit and display rich text in Rails applications"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activestorage-${PV}
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/nokogiri-1.8.5
+"
+
+ruby_add_bdepend "test? (
+ ~dev-ruby/activerecord-${PV}[sqlite]
+ dev-ruby/bundler
+ =dev-ruby/minitest-5.15*:*
+ dev-ruby/mocha
+)"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql2\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|sass-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webpacker\|webrick\|webmock\|webdrivers\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|rack-test\|bootsnap\|capybara\|dalli\|connection_pool\)/ s:^:#:" \
+ -e '/:job/,/end/ s:^:#:' \
+ -e '/group :\(cable\|doc\|rubocop\|storage\|test\)/,/^end/ s:^:#:' \
+ -i ../Gemfile || die
+ rm ../Gemfile.lock || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby:'${RUBY}':' test/dummy/bin/* || die
+}