summaryrefslogtreecommitdiff
path: root/dev-ruby/afm/afm-0.2.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/afm/afm-0.2.2-r1.ebuild')
-rw-r--r--dev-ruby/afm/afm-0.2.2-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/afm/afm-0.2.2-r1.ebuild b/dev-ruby/afm/afm-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..51fbde2f60b2
--- /dev/null
+++ b/dev-ruby/afm/afm-0.2.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A very simple library to read Adobe Font Metrics files"
+HOMEPAGE="https://github.com/halfbyte/afm"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/s/^/#/" Rakefile test/helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test test/test_afm.rb || die
+}