summaryrefslogtreecommitdiff
path: root/dev-ruby/ansi/ansi-1.5.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ansi/ansi-1.5.0-r2.ebuild')
-rw-r--r--dev-ruby/ansi/ansi-1.5.0-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/ansi/ansi-1.5.0-r2.ebuild b/dev-ruby/ansi/ansi-1.5.0-r2.ebuild
new file mode 100644
index 000000000000..8d5e9716b8e1
--- /dev/null
+++ b/dev-ruby/ansi/ansi-1.5.0-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="DEMO.md HISTORY.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The Ruby ANSI project is collection of ANSI escape codes for Ruby"
+HOMEPAGE="https://rubyworks.github.io/ansi/"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+# Tests cause circular dependencies with dev-ruby/qed & dev-ruby/rubytest
+RESTRICT="test"
+
+each_ruby_test() {
+ ${RUBY} -S rubytest -Ilib -Itest test/ || die 'tests failed'
+}