summaryrefslogtreecommitdiff
path: root/dev-ruby/bcat
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/bcat')
-rw-r--r--dev-ruby/bcat/Manifest3
-rw-r--r--dev-ruby/bcat/bcat-0.6.2-r3.ebuild43
-rw-r--r--dev-ruby/bcat/metadata.xml11
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-ruby/bcat/Manifest b/dev-ruby/bcat/Manifest
new file mode 100644
index 000000000000..1ed14d91e85f
--- /dev/null
+++ b/dev-ruby/bcat/Manifest
@@ -0,0 +1,3 @@
+DIST bcat-0.6.2.gem 22016 BLAKE2B abfaec6d9db25990838019d0e9f4dde918f260c01340e34ab272f8a2e02155674ca38bf91843925df31102982cba02ada69abbf7e9ec4b91d4f2cb87b27be339 SHA512 142f853ca0931e5ba300276b1db0977fa275b9b13602940fbaca2c5d32ff881fe753dee25632526a348d71cf71eb6e390aed821b4ba1f48e380d6369ad87ead7
+EBUILD bcat-0.6.2-r3.ebuild 1148 BLAKE2B 2ee48a5c2012d0f9c0356808e35250fe1303b209d2d47bf3f0337980269b4d2614201ab4d55860dc071b4b71daa483923edf5e8888df1cb260abe8c352ff3904 SHA512 a6236d315f9f5a978209b5fa203b1f43a40ae43fea29524ef461a318adfd0c5205da3736b25d422c032a886293e3b1c0752d8ef488df4d92624bb8abfd081695
+MISC metadata.xml 339 BLAKE2B 747035022afc3a66f3a64ab7614290ebff948570e77f0a184eee2cdf20f838e92a6608569714b0c3672660019b1e6002ee65afa3d88e5fc497e147c59cdd2f37 SHA512 e128341196b2b542a7d3a7cdbe576e667ec176b3e231a627cedafbaadac4ede41fd6710722ca880551cf9635e9a8768cf273a6784b276647cf4db250404521dc
diff --git a/dev-ruby/bcat/bcat-0.6.2-r3.ebuild b/dev-ruby/bcat/bcat-0.6.2-r3.ebuild
new file mode 100644
index 000000000000..c5c93022c266
--- /dev/null
+++ b/dev-ruby/bcat/bcat-0.6.2-r3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC="man"
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pipe to browser utility for use at the shell and within editors"
+HOMEPAGE="https://github.com/rtomayko/bcat"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE=""
+
+# Collides on /usr/bin/bcat, bug 418301
+RDEPEND="${RDEPEND} !!<app-accessibility/speech-tools-2.1-r3"
+
+ruby_add_bdepend "doc? ( app-text/ronn )
+ test? ( dev-ruby/test-unit:2 )"
+
+ruby_add_rdepend "=dev-ruby/rack-1*:*"
+
+each_ruby_prepare() {
+ sed -i -e "s/a2h/#{ENV['RUBY']} -S a2h/" test/test_bcat_a2h.rb || die
+}
+
+each_ruby_test() {
+ # The Rakefile uses weird trickery with load path that causes gems
+ # not to be found. Run tests directly instead and do the trickery
+ # here to support popen calls for the bins in this package.
+ RUBY=${RUBY} RUBYLIB=lib:${RUBYLIB} PATH=bin:${PATH} ${RUBY} -S testrb-2 test/test_*.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/*.1
+}
diff --git a/dev-ruby/bcat/metadata.xml b/dev-ruby/bcat/metadata.xml
new file mode 100644
index 000000000000..644bab734fa8
--- /dev/null
+++ b/dev-ruby/bcat/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rtomayko/bcat</remote-id>
+ </upstream>
+</pkgmetadata>