summaryrefslogtreecommitdiff
path: root/dev-ruby/connection_pool/connection_pool-2.2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/connection_pool/connection_pool-2.2.3.ebuild')
-rw-r--r--dev-ruby/connection_pool/connection_pool-2.2.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/connection_pool/connection_pool-2.2.3.ebuild b/dev-ruby/connection_pool/connection_pool-2.2.3.ebuild
new file mode 100644
index 000000000000..194ac6f8667a
--- /dev/null
+++ b/dev-ruby/connection_pool/connection_pool-2.2.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changes.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Generic connection pooling for Ruby"
+HOMEPAGE="https://github.com/mperham/connection_pool"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5 )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' connection_pool.gemspec || die
+ sed -i -e '/\(bundler\|standard\)/ s:^:#:' Rakefile || die
+ sed -i -e "s/gem 'minitest'/gem 'minitest', '~> 5.0'/" test/helper.rb || die
+}