summaryrefslogtreecommitdiff
path: root/dev-ruby/coolio
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/coolio')
-rw-r--r--dev-ruby/coolio/Manifest4
-rw-r--r--dev-ruby/coolio/coolio-1.5.0.ebuild62
-rw-r--r--dev-ruby/coolio/coolio-1.5.1.ebuild57
3 files changed, 0 insertions, 123 deletions
diff --git a/dev-ruby/coolio/Manifest b/dev-ruby/coolio/Manifest
index ec2d5b8450db..317a6509af9a 100644
--- a/dev-ruby/coolio/Manifest
+++ b/dev-ruby/coolio/Manifest
@@ -1,7 +1,3 @@
-DIST cool.io-1.5.0.gem 112128 BLAKE2B e29644b4e2a592f4352141cb3450c90e9b89a2ce490d598695d3318e5722055d56df7ca4d462e0e6facceb5a846c0a654069dc63a2398edc7500d5921426c2ec SHA512 e3089282352eb1f5c08d9cf2c8a8397904eaa3835b1146439c04f104210630b5ae49696716a971a9ba5a33e8cf85f28dc706d211ef47fbe6dfcbbb81a3a87bc1
-DIST cool.io-1.5.1.gem 112128 BLAKE2B 2aba94865094611cc8fa746d4e1e3cec0bea8a762f102e63a5a52cd46d6867e173b406685ca7027f1d9871bf8a0aa6b12c261b95545a288cd2bd61673d807223 SHA512 faf85ca190f7090d288202daf7a74068940402098bcd8ff954e4dc603be9934b332aeb8b43869f56c59a413954e98cbe8a48a554ae65690988a5d9d64169627e
DIST cool.io-1.5.3.gem 112128 BLAKE2B f343ee73e3796744ec21d3af13e92a0a462e10b262543c2d77ab0dd6c5250bbd6cf0d6579646d146983df1c2b288717f3d4e9f1d5d0cded58a9b1422e497dee5 SHA512 6ef61713acdccf951ebd64018a3d9ec83e2655895994fe23842e18cd2556f4d35ec42144577a83b30ef369a9047a58d1bba2224145653db0b7c203dfdca6c3c3
-EBUILD coolio-1.5.0.ebuild 1612 BLAKE2B 64f12933ae5e4feb375a3da2c3f473f03fb802313341bdd71bcd77d87f304aaf6478378f4febd11b912f35fd097662b41c12cabf0811a03bcabc0db5f6c25c5d SHA512 d2e58b5637334c38c702f3f62e32dafb25b742154b54d8f3a6528f218341b1fa3ddd1e0752102aa0893dba7690b60bfc1d2b26faa1598c1b4615739a5bd8bf8f
-EBUILD coolio-1.5.1.ebuild 1449 BLAKE2B da66c0fad63c376ccb419c2ca67b4e886f5a2bc0d2dfb62c8944251033e3a6818a9e41bc027175efb3c3650ecf80ea2dc9ca92c0f60f242765f9299562fe8a43 SHA512 31a64fb532f880a9681b0d4811e985af01934de4afc7ac336580bde79be1275526699401511778521f843d1767e3ebd9dc29b57776b735bd852e825748e5b68d
EBUILD coolio-1.5.3.ebuild 1442 BLAKE2B 7580cb65ae5eebe67e830a37f8b2d3b956cffafdd086e36727f927161af3d086a7d40ca8ba0469f80a94be11565e53cb8101d96b49ae67bfd2e4956613a71e68 SHA512 e12364826839d88823e1c140a978b06e6806b14738359b60e2730bc64d92a726e01b120afa1aafb7349da2d7a733782952c33eafaa1da32acbe871a2cf473da1
MISC metadata.xml 247 BLAKE2B 7717702c51c35b2a20983332abc6218047b2b5036e6b4c09d3d58b4339e8f9e776879cd116cfda60d3bcf4188859993fb9f3f779aaf595f155d53e85288f3dcc SHA512 ea4c044637b751a2c28c6ac226121e74ef18196af4b594e60413fec907bbab29c6b0c7735c3f503485df16dcfb36ddb86038394d92e2cd18c8f04626628e9f09
diff --git a/dev-ruby/coolio/coolio-1.5.0.ebuild b/dev-ruby/coolio/coolio-1.5.0.ebuild
deleted file mode 100644
index f1590fcf5afd..000000000000
--- a/dev-ruby/coolio/coolio-1.5.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby21 ruby22 ruby23"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
-RUBY_FAKEGEM_NAME="cool.io"
-
-RUBY_FAKEGEM_GEMSPEC="cool.io.gemspec"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A high performance event framework for Ruby which uses the libev C library"
-HOMEPAGE="https://coolio.github.io/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# cool.io includes a bundled version of libev that is patched to work correctly with ruby.
-
-ruby_add_rdepend ">=dev-ruby/iobuffer-1"
-
-all_ruby_prepare() {
- rm -r Gemfile* lib/.gitignore || die
-
- sed -i -e '/[Bb]undler/d' Rakefile || die
- sed -i -e '28i s.add_dependency "iobuffer"' ${RUBY_FAKEGEM_GEMSPEC} || die
- sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
-
- # Avoid dependency on rake-compiler
- sed -i -e '/extensiontask/ s:^:#:' \
- -e '/ExtensionTask/,/^end/ s:^:#:' Rakefile || die
-
- # Remove specs that require network connectivity
- rm -f spec/dns_spec.rb || die
-
- # Use one address consistently
- sed -i -e 's/localhost/127.0.0.1/' spec/{udp_socket,tcp_server,iobuffer}_spec.rb || die
-
- # Remove specs that fail, possibly due to libev
- # incompatibility. Should be investigated but cool.io is no longer
- # maintained.
- rm -f spec/udp_socket_spec.rb || die
-}
-
-each_ruby_configure() {
- pushd ext/cool.io || die
- ${RUBY} extconf.rb || die
- popd || die
-}
-
-each_ruby_compile() {
- pushd ext/cool.io || die
- emake V=1
- popd || die
- cp ext/cool.io/cool.io_ext$(get_modname) lib/ || die
-}
diff --git a/dev-ruby/coolio/coolio-1.5.1.ebuild b/dev-ruby/coolio/coolio-1.5.1.ebuild
deleted file mode 100644
index f5e6db466c6e..000000000000
--- a/dev-ruby/coolio/coolio-1.5.1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby21 ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
-RUBY_FAKEGEM_NAME="cool.io"
-
-RUBY_FAKEGEM_GEMSPEC="cool.io.gemspec"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A high performance event framework for Ruby which uses the libev C library"
-HOMEPAGE="https://coolio.github.com/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# cool.io includes a bundled version of libev that is patched to work correctly with ruby.
-
-ruby_add_rdepend ">=dev-ruby/iobuffer-1"
-
-all_ruby_prepare() {
- rm -r Gemfile* lib/.gitignore || die
-
- sed -i -e '/[Bb]undler/d' Rakefile || die
- sed -i -e '28i s.add_dependency "iobuffer"' ${RUBY_FAKEGEM_GEMSPEC} || die
- sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
-
- # Avoid dependency on rake-compiler
- sed -i -e '/extensiontask/ s:^:#:' \
- -e '/ExtensionTask/,/^end/ s:^:#:' Rakefile || die
-
- # Remove specs that require network connectivity
- rm -f spec/dns_spec.rb || die
-
- # Use one address consistently
- sed -i -e 's/localhost/127.0.0.1/' spec/{udp_socket,tcp_server,iobuffer}_spec.rb || die
-}
-
-each_ruby_configure() {
- pushd ext/cool.io || die
- ${RUBY} extconf.rb || die
- popd || die
-}
-
-each_ruby_compile() {
- pushd ext/cool.io || die
- emake V=1
- popd || die
- cp ext/cool.io/cool.io_ext$(get_modname) lib/ || die
-}