summaryrefslogtreecommitdiff
path: root/dev-ruby/getoptlong
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/getoptlong')
-rw-r--r--dev-ruby/getoptlong/Manifest3
-rw-r--r--dev-ruby/getoptlong/getoptlong-0.2.1.ebuild30
-rw-r--r--dev-ruby/getoptlong/metadata.xml11
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/getoptlong/Manifest b/dev-ruby/getoptlong/Manifest
new file mode 100644
index 000000000000..045ee8aa1b6c
--- /dev/null
+++ b/dev-ruby/getoptlong/Manifest
@@ -0,0 +1,3 @@
+DIST getoptlong-0.2.1.tar.gz 10505 BLAKE2B b67b04b6f0952393a4f8e7a0cbeccd1aa78c5580b122f1822e2ffe0fedefa5eb9b77ab7ec8e149099d09a4845673f848e46eb11676b968bdf929ea9f07290162 SHA512 8a2c24ef680d0bbd84f255e69a6da0684199fac01ff24158ad9d28e615f5bc3c139ff0eebd66ab62b11413c85d39b7460b7820e51183eb5c6b75e3f5b61b4a49
+EBUILD getoptlong-0.2.1.ebuild 948 BLAKE2B 266f35d15b2df5483ccd877dca8a3be7bbe487cc4f00933c56465bde3f0b3776fff39366c880a05908a628902f9a6ceab31ce1601bff67108682d1183548bf3a SHA512 f59aa8628bc19f1df0a9627f1c8c22546c653bac0fc842586cb5b02164f3b7a790034a59a93eba15bf98990c8502a3b19221093f5f81e7b967ee42788061e2c7
+MISC metadata.xml 342 BLAKE2B ceb0168c54641e04f8f90e16a488375fba8778ae35c6a110a7d86e494bb8ad7ef870e7dab097bb88948ba982db1dd75407512d8ffb7ad50a090b82be0c6bce83 SHA512 93060b7c9cab8878dd1c8e689998760960d99f4877f56cd9307d274e08730cf2cf421ab8653ecaed1521548e9017e6f6a03293c980858b0dc9583a66c427e4a3
diff --git a/dev-ruby/getoptlong/getoptlong-0.2.1.ebuild b/dev-ruby/getoptlong/getoptlong-0.2.1.ebuild
new file mode 100644
index 000000000000..e1260e1781e6
--- /dev/null
+++ b/dev-ruby/getoptlong/getoptlong-0.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="getoptlong.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Allows you to parse command line options similarly to getopt_long()"
+HOMEPAGE="https://github.com/ruby/getoptlong"
+SRC_URI="https://github.com/ruby/getoptlong/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+all_ruby_prepare() {
+ sed -e 's/__FILE__/"getoptlong.gemspec"/' \
+ -e 's/__dir__/"."/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test:test/lib -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}
diff --git a/dev-ruby/getoptlong/metadata.xml b/dev-ruby/getoptlong/metadata.xml
new file mode 100644
index 000000000000..a8d17c94ea7b
--- /dev/null
+++ b/dev-ruby/getoptlong/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/getoptlong</remote-id>
+ </upstream>
+</pkgmetadata>