summaryrefslogtreecommitdiff
path: root/dev-ruby/listen/listen-0.7.3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/listen/listen-0.7.3-r2.ebuild')
-rw-r--r--dev-ruby/listen/listen-0.7.3-r2.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-ruby/listen/listen-0.7.3-r2.ebuild b/dev-ruby/listen/listen-0.7.3-r2.ebuild
deleted file mode 100644
index 40d05b507c32..000000000000
--- a/dev-ruby/listen/listen-0.7.3-r2.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Listens to file modifications and notifies you about the changes"
-HOMEPAGE="https://github.com/guard/listen"
-SRC_URI="https://github.com/guard/listen/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 x86 ~x64-macos"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/rb-inotify-0.9.0"
-
-all_ruby_prepare() {
- # Avoid a spec with incorrect stubbing.
- sed -i -e '/loads all the registerd dependencies/,/ end/ s:^:#:' \
- -e '/return true when dependencies are loaded/,/ end/ s:^:#:' \
- spec/listen/dependency_manager_spec.rb || die
-}