summaryrefslogtreecommitdiff
path: root/dev-ruby/mail/mail-2.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/mail/mail-2.7.0.ebuild')
-rw-r--r--dev-ruby/mail/mail-2.7.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/mail/mail-2.7.0.ebuild b/dev-ruby/mail/mail-2.7.0.ebuild
new file mode 100644
index 000000000000..37eef9d35b8a
--- /dev/null
+++ b/dev-ruby/mail/mail-2.7.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.md"
+
+RUBY_FAKEGEM_GEMSPEC="mail.gemspec"
+
+inherit ruby-fakegem versionator
+
+GITHUB_USER="mikel"
+
+DESCRIPTION="An email handling library"
+HOMEPAGE="https://github.com/mikel/mail"
+SRC_URI="https://github.com/${GITHUB_USER}/mail/archive/${PV}.tar.gz -> ${P}-git.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/mini_mime-0.1.1"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undle/d' -e '6d' Rakefile || die "Unable to remove Bundler code."
+}