summaryrefslogtreecommitdiff
path: root/dev-ruby/mini_mime/mini_mime-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/mini_mime/mini_mime-1.0.0.ebuild')
-rw-r--r--dev-ruby/mini_mime/mini_mime-1.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/mini_mime/mini_mime-1.0.0.ebuild b/dev-ruby/mini_mime/mini_mime-1.0.0.ebuild
new file mode 100644
index 000000000000..0b5b3fd28ce0
--- /dev/null
+++ b/dev-ruby/mini_mime/mini_mime-1.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="mini_mime.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A lightweight mime type lookup toy"
+HOMEPAGE="https://github.com/discourse/mini_mime"
+SRC_URI="https://github.com/discourse/mini_mime/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc"
+IUSE="test"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}