summaryrefslogtreecommitdiff
path: root/dev-ruby/oauth2
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/oauth2')
-rw-r--r--dev-ruby/oauth2/Manifest2
-rw-r--r--dev-ruby/oauth2/oauth2-2.0.9.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-ruby/oauth2/Manifest b/dev-ruby/oauth2/Manifest
index 6a33b243ebae..03abbd32693c 100644
--- a/dev-ruby/oauth2/Manifest
+++ b/dev-ruby/oauth2/Manifest
@@ -1,3 +1,5 @@
DIST oauth2-1.4.11.tar.bz2 65622 BLAKE2B 9a09e69eb2389289d5b048388dd52dd6edcf289c4d7262ead05cca7dd27b261b6f432e023ac3c34aa77d6fa33bca5d870726b96cf5bf85eeec3561e9b53f9501 SHA512 12a9133cd5813eed00c2a22995630a7fdb611b0d76b06eeb8c938fd826831ea37556822246f21a739ba427c74135e6c2046edc1fb008725c55f3b1000ab5a945
+DIST oauth2-2.0.9.tar.bz2 86459 BLAKE2B ba5623cf81824468489d68a4a06d1677ae05931e92471ea5c536292e5f688f4208915552a1cced22b66906149fe5c12a6da4ab6cc4a724ad3fce721b828a4f1e SHA512 d5d80bb3f34daf63d1723791d158abbaa53fbb9a1d85401267079762066c4fb031ef7ab7d259cdb7b351024ff5a35a22a55080dadc44d52dd32515df1ebfbce6
EBUILD oauth2-1.4.11.ebuild 1581 BLAKE2B 6523f01566c69882db4cd606d1fb99c0aafbb008726ea8d34c260b0d35e77d01984259517f3d3de5522f63f472fdebf7b33b87138745f963e228a706716fd3c7 SHA512 6dde5179a9427377d037cc7aeb374cdfd010af0b7eac77cd5b36699058d5bf52426a4322d2c068fa72a28944907ddd594f47e12c898f2fac29ec07e2fdee5075
+EBUILD oauth2-2.0.9.ebuild 2352 BLAKE2B cf351e3d76692bfe96c522cc36727ea88a4882c0870ad7a79d0ca3642359c2ff389951356a31ec1a6d2b5375660e201955d30ab73663fb5c920b8aebed6eb734 SHA512 d484e4a01173dcd88e67cf6875d747e316de7c2d34e09c3ffc640c5a69e82e2e76b7c3d1dcd3f2c20cb6fa86b8068d5649dce112743f04d56e8719fed3b145ee
MISC metadata.xml 342 BLAKE2B 0080dc708a99cdd0861b14ecd773251e5719b249171dfaca247f241b1cab03c83bb2593b31a26dcbd02c5767bb27d385600b0dfdd4c8771c9d8b78fd55a26682 SHA512 a8b1d3f086a524b4b4b48465cb26707cacc4a7862ba46639946b67e822df34fdd5bb0fbde7daa3712dfcf9ec08946125710abb79d0e97dd6a819201d3b88df3d
diff --git a/dev-ruby/oauth2/oauth2-2.0.9.ebuild b/dev-ruby/oauth2/oauth2-2.0.9.ebuild
new file mode 100644
index 000000000000..f6dad2a18743
--- /dev/null
+++ b/dev-ruby/oauth2/oauth2-2.0.9.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="oauth2.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Wrapper for the OAuth 2.0 protocol with a similar style to the OAuth gem"
+HOMEPAGE="https://gitlab.com/oauth-xx/oauth2"
+SRC_URI="https://gitlab.com/oauth-xx/oauth2/-/archive/v${PV}/oauth2-${PV}.tar.bz2"
+RUBY_S="oauth2-v${PV}-*"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+ruby_add_rdepend "
+ || ( dev-ruby/faraday:2 dev-ruby/faraday:1 )
+ dev-ruby/jwt:2
+ >=dev-ruby/multi_xml-0.5:0
+ >=dev-ruby/rack-1.2:* <dev-ruby/rack-4:*
+ dev-ruby/snaky_hash:1
+ >=dev-ruby/version_gem-1.1:1
+"
+ruby_add_bdepend "test? (
+ >=dev-ruby/addressable-2.3
+ >=dev-ruby/backports-3
+ >=dev-ruby/rexml-3.2:3
+ dev-ruby/rspec:3
+ dev-ruby/rspec-pending_for
+ dev-ruby/rspec-stubbed_env
+)"
+
+all_ruby_prepare() {
+ sed \
+ -e '/silent/I s:^:#:' \
+ -e '/require.*oauth2/arequire "oauth2/version"' \
+ -i spec/spec_helper.rb || die
+
+ sed -i -e '/yardstick/,/^end/ s:^:#:' \
+ -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Avoid spec that is too fragile in relation to ENV
+ sed -i -e '/outputs to $stdout when OAUTH_DEBUG=true/a skip "fragile ENV stubbing"' spec/oauth2/client_spec.rb || die
+
+ # Avoid specs depending on unpackaged silent_stream gem
+ sed -e '/with warning for \(no\|too many\) token/ s/context/xcontext/' \
+ -e '/with keys in a different order to the lookup/ s/context/xcontext/' \
+ -i spec/oauth2/access_token_spec.rb || die
+ sed -e '/when OAUTH_DEBUG=\(false\|true\)/ s/context/xcontext/' \
+ -e '/with extract_access_token option/ s/describe/xdescribe/' \
+ -i spec/oauth2/client_spec.rb || die
+
+ # Avoid specs failing due to differences in errors in newer versions
+ # of dependencies.
+ sed -e '/when parse: :xml but response is JSON/ s/context/xcontext/' \
+ -i spec/oauth2/client_spec.rb || die
+ sed -e '/with bad encoding params/ s/context/xcontext/' \
+ -i spec/oauth2/strategy/assertion_spec.rb || die
+
+ sed -e 's/git ls-files -z/find * -print0/' \
+ -e "s:_relative ': './:" \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ CI=true ${RUBY} -S rspec-3 --format progress spec || die
+}