summaryrefslogtreecommitdiff
path: root/dev-ruby/ptools/ptools-1.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ptools/ptools-1.5.0.ebuild')
-rw-r--r--dev-ruby/ptools/ptools-1.5.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/ptools/ptools-1.5.0.ebuild b/dev-ruby/ptools/ptools-1.5.0.ebuild
new file mode 100644
index 000000000000..b9c0e5c85b5b
--- /dev/null
+++ b/dev-ruby/ptools/ptools-1.5.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Several handy methods to Ruby's core File class"
+HOMEPAGE="https://github.com/djberg96/ptools"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+#ruby_add_bdepend "test? ( dev-ruby/mkmf-lite )"