summaryrefslogtreecommitdiff
path: root/dev-ruby/rack
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rack')
-rw-r--r--dev-ruby/rack/Manifest1
-rw-r--r--dev-ruby/rack/files/rack-2.2.3.1-ruby30.patch210
2 files changed, 0 insertions, 211 deletions
diff --git a/dev-ruby/rack/Manifest b/dev-ruby/rack/Manifest
index 191bd549ae0c..55add7bdc217 100644
--- a/dev-ruby/rack/Manifest
+++ b/dev-ruby/rack/Manifest
@@ -1,4 +1,3 @@
-AUX rack-2.2.3.1-ruby30.patch 7607 BLAKE2B c9f39f901fbc809093cfb4702fed3495dc1091ef0241f0df20fef4659f667e65ab93d96a9128a6b2c47e809cfb4a63b8834c46898edbb59dfd0d824066802e0b SHA512 13b7a938d9af575362d39b06bb3a50ce1fb7afe632c02a5c3cd46670518752d4dccee56da055c6d67da503df971ecce0ae744e2d2e6cca513483561f695e081e
DIST rack-2.2.4.tar.gz 278632 BLAKE2B 2d12a9c1e239590a4aedea5f3bb4c171b6032255658688a151e665aa1cb33dee17754c7b2736f8f1725c70b8344f5f6664cace8c4d4cb4e9f6f2ee1c7a3117c0 SHA512 aef54a06efce54d58e600829bbf550162bf68fe710b61b2b81022b2a8581819fb575e03992f493f11ed5f3391349f21cd142f6acc5b6017ec4c8e21cb17e4874
EBUILD rack-2.2.4.ebuild 1708 BLAKE2B 9db82605b298705172d939cc7acdcb07ea1f5a6439d6ce6f0964326d27f6376c2648381b6e808b4c0ed269f77c72a5b41c8f54dd153759899fa6cb27c58ed1df SHA512 69db8c6487db112df55989c59c7e6f09c16f8063de327658bd0d8646f3bddc84899e0828fb179903798d69eaa16cea8cde056b9ccf0363dc335eed959b585a39
MISC metadata.xml 392 BLAKE2B 625ee54c32c0350c08e68ec422fd024c364bf2dc26b5402363db0909d5720fea9a8741cf7ef8bcdcec21bcf3ee4efb6ccc514231d12ceb87b927035ee5a1d408 SHA512 96436f55bc9e3d93373e6e3c4858048aef3811654f8d5f11aa9b37b89b012e0d1770c1617764b4ef72d5e4656b0113a1bf15f9398c9bc23f55de774591020afc
diff --git a/dev-ruby/rack/files/rack-2.2.3.1-ruby30.patch b/dev-ruby/rack/files/rack-2.2.3.1-ruby30.patch
deleted file mode 100644
index 467fb3487d67..000000000000
--- a/dev-ruby/rack/files/rack-2.2.3.1-ruby30.patch
+++ /dev/null
@@ -1,210 +0,0 @@
-From 43b5565a73817d66b6d96de2e28d525a2a56f852 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Josef=20=C5=A0im=C3=A1nek?= <josef.simanek@gmail.com>
-Date: Mon, 4 Apr 2022 23:17:19 +0200
-Subject: [PATCH] Newer rubies spec compatibility.
-
----
- Gemfile | 5 +++++
- lib/rack/utils.rb | 7 +++++--
- test/spec_mock.rb | 34 +++++++++++++++++-----------------
- test/testrequest.rb | 4 ++--
- 4 files changed, 29 insertions(+), 21 deletions(-)
-
-diff --git a/Gemfile b/Gemfile
-index dc075a4ca..5768eedf7 100644
---- a/Gemfile
-+++ b/Gemfile
-@@ -14,6 +14,11 @@ end
-
- gem "rubocop", require: false
-
-+group :test do
-+ gem "webrick" # gemified in Ruby 3.1+
-+ gem "psych", "~> 4.0" # using YAML#unsafe_load in tests which is 4.0+ only
-+end
-+
- # Alternative solution that might work, but it has bad interactions with
- # Gemfile.lock if that gets committed/reused:
- # c_platforms = [:mri] if Gem.platforms.last.os == "java"
-diff --git a/lib/rack/utils.rb b/lib/rack/utils.rb
-index d3b3b1d42..34849ded1 100644
---- a/lib/rack/utils.rb
-+++ b/lib/rack/utils.rb
-@@ -22,6 +22,9 @@ module Utils
- COMMON_SEP = QueryParser::COMMON_SEP
- KeySpaceConstrainedParams = QueryParser::Params
-
-+ RFC2822_DAY_NAME = [ 'Sun', 'Mon', 'Tue', 'Wed', 'Thu', 'Fri', 'Sat' ]
-+ RFC2822_MONTH_NAME = [ 'Jan', 'Feb', 'Mar', 'Apr', 'May', 'Jun', 'Jul', 'Aug', 'Sep', 'Oct', 'Nov', 'Dec' ]
-+
- class << self
- attr_accessor :default_query_parser
- end
-@@ -327,8 +330,8 @@ def rfc2822(time)
- # weekday and month.
- #
- def rfc2109(time)
-- wday = Time::RFC2822_DAY_NAME[time.wday]
-- mon = Time::RFC2822_MONTH_NAME[time.mon - 1]
-+ wday = RFC2822_DAY_NAME[time.wday]
-+ mon = RFC2822_MONTH_NAME[time.mon - 1]
- time.strftime("#{wday}, %d-#{mon}-%Y %H:%M:%S GMT")
- end
-
-diff --git a/test/spec_mock.rb b/test/spec_mock.rb
-index d2311f5a2..73fb7b235 100644
---- a/test/spec_mock.rb
-+++ b/test/spec_mock.rb
-@@ -47,7 +47,7 @@
- it "provide sensible defaults" do
- res = Rack::MockRequest.new(app).request
-
-- env = YAML.load(res.body)
-+ env = YAML.unsafe_load(res.body)
- env["REQUEST_METHOD"].must_equal "GET"
- env["SERVER_NAME"].must_equal "example.org"
- env["SERVER_PORT"].must_equal "80"
-@@ -60,23 +60,23 @@
-
- it "allow GET/POST/PUT/DELETE/HEAD" do
- res = Rack::MockRequest.new(app).get("", input: "foo")
-- env = YAML.load(res.body)
-+ env = YAML.unsafe_load(res.body)
- env["REQUEST_METHOD"].must_equal "GET"
-
- res = Rack::MockRequest.new(app).post("", input: "foo")
-- env = YAML.load(res.body)
-+ env = YAML.unsafe_load(res.body)
- env["REQUEST_METHOD"].must_equal "POST"
-
- res = Rack::MockRequest.new(app).put("", input: "foo")
-- env = YAML.load(res.body)
-+ env = YAML.unsafe_load(res.body)
- env["REQUEST_METHOD"].must_equal "PUT"
-
- res = Rack::MockRequest.new(app).patch("", input: "foo")
-- env = YAML.load(res.body)
-+ env = YAML.unsafe_load(res.body)
- env["REQUEST_METHOD"].must_equal "PATCH"
-
- res = Rack::MockRequest.new(app).delete("", input: "foo")
-- env = YAML.load(res.body)
-+ env = YAML.unsafe_load(res.body)
- env["REQUEST_METHOD"].must_equal "DELETE"
-
- Rack::MockRequest.env_for("/", method: "HEAD")["REQUEST_METHOD"]
-@@ -102,11 +102,11 @@
-
- it "allow posting" do
- res = Rack::MockRequest.new(app).get("", input: "foo")
-- env = YAML.load(res.body)
-+ env = YAML.unsafe_load(res.body)
- env["mock.postdata"].must_equal "foo"
-
- res = Rack::MockRequest.new(app).post("", input: StringIO.new("foo"))
-- env = YAML.load(res.body)
-+ env = YAML.unsafe_load(res.body)
- env["mock.postdata"].must_equal "foo"
- end
-
-@@ -115,7 +115,7 @@
- get("https://bla.example.org:9292/meh/foo?bar")
- res.must_be_kind_of Rack::MockResponse
-
-- env = YAML.load(res.body)
-+ env = YAML.unsafe_load(res.body)
- env["REQUEST_METHOD"].must_equal "GET"
- env["SERVER_NAME"].must_equal "bla.example.org"
- env["SERVER_PORT"].must_equal "9292"
-@@ -129,7 +129,7 @@
- get("https://example.org/foo")
- res.must_be_kind_of Rack::MockResponse
-
-- env = YAML.load(res.body)
-+ env = YAML.unsafe_load(res.body)
- env["REQUEST_METHOD"].must_equal "GET"
- env["SERVER_NAME"].must_equal "example.org"
- env["SERVER_PORT"].must_equal "443"
-@@ -144,7 +144,7 @@
- get("foo")
- res.must_be_kind_of Rack::MockResponse
-
-- env = YAML.load(res.body)
-+ env = YAML.unsafe_load(res.body)
- env["REQUEST_METHOD"].must_equal "GET"
- env["SERVER_NAME"].must_equal "example.org"
- env["SERVER_PORT"].must_equal "80"
-@@ -155,13 +155,13 @@
-
- it "properly convert method name to an uppercase string" do
- res = Rack::MockRequest.new(app).request(:get)
-- env = YAML.load(res.body)
-+ env = YAML.unsafe_load(res.body)
- env["REQUEST_METHOD"].must_equal "GET"
- end
-
- it "accept params and build query string for GET requests" do
- res = Rack::MockRequest.new(app).get("/foo?baz=2", params: { foo: { bar: "1" } })
-- env = YAML.load(res.body)
-+ env = YAML.unsafe_load(res.body)
- env["REQUEST_METHOD"].must_equal "GET"
- env["QUERY_STRING"].must_include "baz=2"
- env["QUERY_STRING"].must_include "foo[bar]=1"
-@@ -171,7 +171,7 @@
-
- it "accept raw input in params for GET requests" do
- res = Rack::MockRequest.new(app).get("/foo?baz=2", params: "foo[bar]=1")
-- env = YAML.load(res.body)
-+ env = YAML.unsafe_load(res.body)
- env["REQUEST_METHOD"].must_equal "GET"
- env["QUERY_STRING"].must_include "baz=2"
- env["QUERY_STRING"].must_include "foo[bar]=1"
-@@ -181,7 +181,7 @@
-
- it "accept params and build url encoded params for POST requests" do
- res = Rack::MockRequest.new(app).post("/foo", params: { foo: { bar: "1" } })
-- env = YAML.load(res.body)
-+ env = YAML.unsafe_load(res.body)
- env["REQUEST_METHOD"].must_equal "POST"
- env["QUERY_STRING"].must_equal ""
- env["PATH_INFO"].must_equal "/foo"
-@@ -191,7 +191,7 @@
-
- it "accept raw input in params for POST requests" do
- res = Rack::MockRequest.new(app).post("/foo", params: "foo[bar]=1")
-- env = YAML.load(res.body)
-+ env = YAML.unsafe_load(res.body)
- env["REQUEST_METHOD"].must_equal "POST"
- env["QUERY_STRING"].must_equal ""
- env["PATH_INFO"].must_equal "/foo"
-@@ -202,7 +202,7 @@
- it "accept params and build multipart encoded params for POST requests" do
- files = Rack::Multipart::UploadedFile.new(File.join(File.dirname(__FILE__), "multipart", "file1.txt"))
- res = Rack::MockRequest.new(app).post("/foo", params: { "submit-name" => "Larry", "files" => files })
-- env = YAML.load(res.body)
-+ env = YAML.unsafe_load(res.body)
- env["REQUEST_METHOD"].must_equal "POST"
- env["QUERY_STRING"].must_equal ""
- env["PATH_INFO"].must_equal "/foo"
-diff --git a/test/testrequest.rb b/test/testrequest.rb
-index aabe7fa6b..481a4e54d 100644
---- a/test/testrequest.rb
-+++ b/test/testrequest.rb
-@@ -42,7 +42,7 @@ def GET(path, header = {})
- http.request(get) { |response|
- @status = response.code.to_i
- begin
-- @response = YAML.load(response.body)
-+ @response = YAML.unsafe_load(response.body)
- rescue TypeError, ArgumentError
- @response = nil
- end
-@@ -60,7 +60,7 @@ def POST(path, formdata = {}, header = {})
- post.basic_auth user, passwd if user && passwd
- http.request(post) { |response|
- @status = response.code.to_i
-- @response = YAML.load(response.body)
-+ @response = YAML.unsafe_load(response.body)
- }
- }
- end