summaryrefslogtreecommitdiff
path: root/dev-ruby/recog/recog-2.3.20.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/recog/recog-2.3.20.ebuild')
-rw-r--r--dev-ruby/recog/recog-2.3.20.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/recog/recog-2.3.20.ebuild b/dev-ruby/recog/recog-2.3.20.ebuild
new file mode 100644
index 000000000000..18077246bb19
--- /dev/null
+++ b/dev-ruby/recog/recog-2.3.20.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="xml"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pattern recognition for hosts, services, and content"
+HOMEPAGE="https://github.com/rapid7/recog"
+
+LICENSE="BSD-2"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/nokogiri"
+
+ruby_add_bdepend "test? (
+ dev-ruby/regexp_parser
+ dev-ruby/rspec:3
+ dev-util/aruba:1
+ dev-util/cucumber
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+}
+
+each_ruby_test() {
+ RSPEC_VERSION=3 ruby-ng_rspec
+ ruby-ng_cucumber
+}