summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec-expectations/rspec-expectations-3.12.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rspec-expectations/rspec-expectations-3.12.3.ebuild')
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-3.12.3.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-3.12.3.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-3.12.3.ebuild
index f350cbe37113..8af717f5741a 100644
--- a/dev-ruby/rspec-expectations/rspec-expectations-3.12.3.ebuild
+++ b/dev-ruby/rspec-expectations/rspec-expectations-3.12.3.ebuild
@@ -36,6 +36,9 @@ all_ruby_prepare() {
# Don't set up bundler: it doesn't understand our setup.
sed -i -e '/[Bb]undler/d' Rakefile || die
+ # Fix minitest deprecation
+ sed -i -e 's/MiniTest/Minitest/' spec/rspec/expectations/minitest_integration_spec.rb || die
+
# Remove the Gemfile to avoid running through 'bundle exec'
rm -f Gemfile || die