summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-augeas/ruby-augeas-0.5.0-r5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-augeas/ruby-augeas-0.5.0-r5.ebuild')
-rw-r--r--dev-ruby/ruby-augeas/ruby-augeas-0.5.0-r5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/ruby-augeas/ruby-augeas-0.5.0-r5.ebuild b/dev-ruby/ruby-augeas/ruby-augeas-0.5.0-r5.ebuild
new file mode 100644
index 000000000000..a5c787b439de
--- /dev/null
+++ b/dev-ruby/ruby-augeas/ruby-augeas-0.5.0-r5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_DOCDIR="doc/site/api"
+RUBY_FAKEGEM_EXTRADOC="NEWS README.rdoc"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/augeas/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby bindings for Augeas"
+HOMEPAGE="https://augeas.net/"
+SRC_URI="http://download.augeas.net/ruby/${P}.gem"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=app-admin/augeas-1.1.0"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2"