summaryrefslogtreecommitdiff
path: root/dev-ruby/stringex/stringex-2.8.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/stringex/stringex-2.8.2.ebuild')
-rw-r--r--dev-ruby/stringex/stringex-2.8.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/stringex/stringex-2.8.2.ebuild b/dev-ruby/stringex/stringex-2.8.2.ebuild
new file mode 100644
index 000000000000..dea7e6cb5f89
--- /dev/null
+++ b/dev-ruby/stringex/stringex-2.8.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_DOC_DIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Extensions for Ruby's String class"
+HOMEPAGE="https://github.com/rsl/stringex"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+IUSE="test"
+
+# we could rely on activerecord[sqlite3], but since we do not remove the
+# sqlite3 adapter from activerecord when building -sqlite3, it's easier
+# to just add another dependency, so the user doesn't have to change the
+# USE flags at all.
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/i18n-0.7.0:0.7
+ dev-ruby/redcloth
+ dev-ruby/test-unit:2
+ >=dev-ruby/activerecord-3
+ dev-ruby/sqlite3 )"
+
+all_ruby_prepare() {
+ sed -i -e '1agem "i18n", "~>0.7.0"' test/test_helper.rb || die
+}