summaryrefslogtreecommitdiff
path: root/dev-ruby/test-unit/test-unit-2.5.5-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/test-unit/test-unit-2.5.5-r2.ebuild')
-rw-r--r--dev-ruby/test-unit/test-unit-2.5.5-r2.ebuild18
1 files changed, 2 insertions, 16 deletions
diff --git a/dev-ruby/test-unit/test-unit-2.5.5-r2.ebuild b/dev-ruby/test-unit/test-unit-2.5.5-r2.ebuild
index 5c143bad133a..2839444f6700 100644
--- a/dev-ruby/test-unit/test-unit-2.5.5-r2.ebuild
+++ b/dev-ruby/test-unit/test-unit-2.5.5-r2.ebuild
@@ -2,20 +2,14 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-USE_RUBY="ruby21 ruby22"
+USE_RUBY="ruby22"
-RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="TODO README.textile"
inherit ruby-fakegem
-# Assume for now that ruby21 is not eselected yet and only depend on
-# yard for the other ruby implementations. Without this assumption
-# bootstrapping ruby21 won't be possible due to the yard dependency
-# tree.
-USE_RUBY="${USE_RUBY/ruby21/}" ruby_add_bdepend "doc? ( dev-ruby/yard )"
-
DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
HOMEPAGE="http://test-unit.rubyforge.org/"
@@ -24,14 +18,6 @@ SLOT="2"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
IUSE="doc test"
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc; then
- yard doc --title ${PN} || die
- fi
-}
-
each_ruby_test() {
${RUBY} test/run-test.rb || die "testsuite failed"
}