summaryrefslogtreecommitdiff
path: root/dev-ruby/textpow/textpow-1.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/textpow/textpow-1.4.0.ebuild')
-rw-r--r--dev-ruby/textpow/textpow-1.4.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/textpow/textpow-1.4.0.ebuild b/dev-ruby/textpow/textpow-1.4.0.ebuild
new file mode 100644
index 000000000000..94931ad65178
--- /dev/null
+++ b/dev-ruby/textpow/textpow-1.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/grosser/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="A library to parse and process Textmate bundles"
+HOMEPAGE="http://textpow.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/plist-3.0.1"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' textpow.gemspec || die
+}