summaryrefslogtreecommitdiff
path: root/dev-ruby/tidy_table/tidy_table-0.0.5-r6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/tidy_table/tidy_table-0.0.5-r6.ebuild')
-rw-r--r--dev-ruby/tidy_table/tidy_table-0.0.5-r6.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/tidy_table/tidy_table-0.0.5-r6.ebuild b/dev-ruby/tidy_table/tidy_table-0.0.5-r6.ebuild
new file mode 100644
index 000000000000..52707fd36dd7
--- /dev/null
+++ b/dev-ruby/tidy_table/tidy_table-0.0.5-r6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Tool to convert an array of struct into an HTML table"
+HOMEPAGE="https://github.com/topfunky/tidy_table"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Remove reference to RSpec 1
+ sed -i -e '/spec/d' -e '1irequire "date"' spec/spec_helper.rb || die
+
+ # Remove metadata so a stub gemspec will be created to avoid the
+ # wrong runtime dependency on dev-ruby/hoe.
+ rm -f ../metadata || die
+}