summaryrefslogtreecommitdiff
path: root/dev-ruby/tilt
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/tilt')
-rw-r--r--dev-ruby/tilt/Manifest2
-rw-r--r--dev-ruby/tilt/tilt-2.0.10.ebuild47
2 files changed, 0 insertions, 49 deletions
diff --git a/dev-ruby/tilt/Manifest b/dev-ruby/tilt/Manifest
index bc1fd2a3503c..9928fb680e58 100644
--- a/dev-ruby/tilt/Manifest
+++ b/dev-ruby/tilt/Manifest
@@ -1,5 +1,3 @@
-DIST tilt-2.0.10.tar.gz 51446 BLAKE2B de5c12dcf22994f182ae163a82c3060f1d0d8b4bc2a4495f28c9befc954b4949b9d2ae6aed42e3a9c35fb68825844881d9f15b2b68d949236e5396083ff199a3 SHA512 4a36c55347e307ea0c842aad3da72cebe98bcf8a0421040cfce7a43540d1746e736ce92b7ce7492a5cfc184372842c3ac7a006f3650b4c9420d5825ec005b4ef
DIST tilt-2.0.9.gem 55296 BLAKE2B dd181295d2317ef591e9b89a0a4cf29680a05403c89c33680f563459ebbfc675bfaef14c864f8c8834103fc2ea069b33dc928f2b804d911eec21b09427f7c619 SHA512 522b2b40ca1eefc7df66cb421c66734699a2ffb1e7d1797181c2718f7ca018d3376c1a2b3617b5d3549115af69108db4c3c4632e2682329d5baf24bfdae92b42
-EBUILD tilt-2.0.10.ebuild 1673 BLAKE2B e1a28206b30dc12a40eea460b9618f62fd213cf8cd9c9118397eba55dcbf3e500cecb1625a095b54d28d46e208a0072ec00a099e6208c66430341060d4bd6147 SHA512 969a44aee8282c24cb23595d077d00fb83e3087713759f3615f7ff648f954ed11ec611de47f1966fa1ede388f97d2cbdc41fa3d58ed22908322dff41c685c333
EBUILD tilt-2.0.9.ebuild 1431 BLAKE2B d875c6011b1cb8ace332e6cf0eb35f9252244ad1e4113286ffc7ea985eb0c6553dca4ad85d8d36322b59dc200bcf7f2e45c9e4fa2886f0b5601b82c907c0819a SHA512 7c457bfe7bb81e1265c888fbd7bdbdcf95b2d8e93c400d0cc75079313be6034ea583842f87d00b220dc428227c0f593ff861e014c1b687df0d5f5bafca31898b
MISC metadata.xml 339 BLAKE2B d8712c61994758c250248bbd14842a7b64d7808008e3d18fac9330bdc03dcbc6e721ffbb2cb813dea148036bcc40a60c4d8b1588b937a02712eb65c312ddb2db SHA512 f9ee61c88fa51f3fed6864d91c8f77bdcb492befce86f260a49faf141d6c11fc4563e57e1b35511571ec02a41cdb8f2111bb7ee76474d1bc65d81bbace15b730
diff --git a/dev-ruby/tilt/tilt-2.0.10.ebuild b/dev-ruby/tilt/tilt-2.0.10.ebuild
deleted file mode 100644
index 9be8e3dee57d..000000000000
--- a/dev-ruby/tilt/tilt-2.0.10.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/TEMPLATES.md"
-
-RUBY_FAKEGEM_GEMSPEC="tilt.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Thin interface over template engines to make their usage as generic as possible"
-HOMEPAGE="https://github.com/rtomayko/tilt"
-SRC_URI="https://github.com/rtomayko/tilt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-# Block on some of the potential test dependencies. These dependencies
-# are optional for the test suite, and we don't want to depend on all of
-# them to faciliate keywording and stabling.
-ruby_add_bdepend "test? (
- dev-ruby/coffee-script
- dev-ruby/erubis
- dev-ruby/nokogiri
- !!<dev-ruby/maruku-0.7.2 )"
-
-ruby_add_rdepend "!!<dev-ruby/tilt-1.4.1-r2:0"
-
-all_ruby_prepare() {
- rm Gemfile || die
- sed -e '/bundler/I s:^:#:' -i Rakefile test/test_helper.rb || die
-
- # Avoid tests with minor syntax differences since this happens all
- # the time when details in the dependencies change.
- sed -e '/test_smarty_pants_true/,/^ end/ s:^:#:' \
- -e '/test_smart_quotes_true/,/^ end/ s:^:#:' -i test/tilt_markdown_test.rb || die
- sed -e '/smartypants when :smart is set/,/^ end/ s:^:#:' -i test/tilt_rdiscounttemplate_test.rb || die
-
- # Skip tests for unpackaged asciidoctor converter
- sed -i -e '/docbook 4.5/askip' test/tilt_asciidoctor_test.rb || die
-}