summaryrefslogtreecommitdiff
path: root/dev-ruby/tilt
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/tilt')
-rw-r--r--dev-ruby/tilt/Manifest2
-rw-r--r--dev-ruby/tilt/tilt-2.5.0.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/tilt/Manifest b/dev-ruby/tilt/Manifest
index 9f4783c70310..4ce0ac693fe5 100644
--- a/dev-ruby/tilt/Manifest
+++ b/dev-ruby/tilt/Manifest
@@ -1,3 +1,5 @@
DIST tilt-2.4.0.tar.gz 58520 BLAKE2B fe07437d62de1db062625c1ead3a81ed34bba0c7169181d44216b5f42b1b742b2c7900c079affbae13831d1370044827384da4302b6e92a01f151b36b37f3772 SHA512 3053479b9f258e01620db5f4af02247179df39f18baae2b5b83eac23046effafcd6f47575432158bb752e3019dcb0aadb67ca11236a12ea01e2211354b7418d1
+DIST tilt-2.5.0.tar.gz 57181 BLAKE2B 27f2eccaec18c7e87ac30680ad94f9202f9608a384d4391e90cc882a4ed82e8b977d89c275202d67e5f30581104a5279e88d47288e709567d65940c18c8d585f SHA512 d27e08e773dd83cf9310ae2879a3a558ecdf686f105c6f03588646ba771933533f75c0132b404c846dfd10087cd6e9aa2cc7fe41076bb4e84766c79f0b98538f
EBUILD tilt-2.4.0.ebuild 1072 BLAKE2B 0dd254420285ea12e41fd88495f700f68f6154b2b906643721079cf6249995ddd3d9070afe3324ce95dc1b05b83656d0baa1f469151e73665d249dda78b42813 SHA512 e823131d58b9d4c89d579b552753377b3008900e3e187efd00111f99e965f0d98ead4074ae56d3deb1f190e7dbbce3b88dcde62ff8b351daf9fd8dac24e69db3
+EBUILD tilt-2.5.0.ebuild 1078 BLAKE2B a0a4134c47c4037dd37c6769e174489348157ebec54b6a0654452ceb5a04f2a3b59c26aea4193a6d3c480090cf3746efcbda3a38a4c78517d93d4382c7e2aa93 SHA512 8a5c1e6267a8c0c6f2b2c84b6cd297fd3acba622c6c87050dd99ecef5086d0bd956b6cff4e5e042015bb8616b7d895a6b28bedee19718e595348f3c0b6bf2057
MISC metadata.xml 340 BLAKE2B 5414049365511f348e3da85bf3f207b791dc4269331e6a650f90398b6afe2502e2e62624ec9597a2d55dca4a7e4a99e209837c44bac7a901ec42139518f41647 SHA512 4be8002eca7cc4c0204311dd7dd187caeee3f40db9b00d108fb18e97009f8cec10d298a958bf83d24177297cebd78789cdd546a0c5e9c7288aa697dee1facf71
diff --git a/dev-ruby/tilt/tilt-2.5.0.ebuild b/dev-ruby/tilt/tilt-2.5.0.ebuild
new file mode 100644
index 000000000000..b76fb674cff9
--- /dev/null
+++ b/dev-ruby/tilt/tilt-2.5.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/TEMPLATES.md"
+
+RUBY_FAKEGEM_GEMSPEC="tilt.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Thin interface over template engines to make their usage as generic as possible"
+HOMEPAGE="https://github.com/jeremyevans/tilt"
+SRC_URI="https://github.com/jeremyevans/tilt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+# Block on some of the potential test dependencies. These dependencies
+# are optional for the test suite, and we don't want to depend on all of
+# them to facilitate keywording and stabling.
+ruby_add_bdepend "test? (
+ dev-ruby/erubi
+ dev-ruby/nokogiri
+)"
+
+all_ruby_prepare() {
+ sed -e '/bundler/I s:^:#:' -i Rakefile test/test_helper.rb || die
+ sed -e '7irequire "uri"' -i test/test_helper.rb || die
+}