summaryrefslogtreecommitdiff
path: root/dev-scheme/gauche-kakasi/gauche-kakasi-0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/gauche-kakasi/gauche-kakasi-0.1.ebuild')
-rw-r--r--dev-scheme/gauche-kakasi/gauche-kakasi-0.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-scheme/gauche-kakasi/gauche-kakasi-0.1.ebuild b/dev-scheme/gauche-kakasi/gauche-kakasi-0.1.ebuild
new file mode 100644
index 000000000000..fd5ecde1baa4
--- /dev/null
+++ b/dev-scheme/gauche-kakasi/gauche-kakasi-0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+IUSE=""
+
+MY_P="${P/g/G}"
+
+DESCRIPTION="Kakasi binding for Gauche"
+HOMEPAGE="http://gauche.sf.net/"
+SRC_URI="mirror://sourceforge/gauche/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=">=dev-scheme/gauche-0.8
+ >=app-i18n/kakasi-2.3.4"
+
+src_compile() {
+
+ econf || die
+ emake || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS ChangeLog README*
+
+}