summaryrefslogtreecommitdiff
path: root/dev-scheme/guile-gcrypt/guile-gcrypt-0.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-scheme/guile-gcrypt/guile-gcrypt-0.2.1.ebuild')
-rw-r--r--dev-scheme/guile-gcrypt/guile-gcrypt-0.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-scheme/guile-gcrypt/guile-gcrypt-0.2.1.ebuild b/dev-scheme/guile-gcrypt/guile-gcrypt-0.2.1.ebuild
new file mode 100644
index 000000000000..05bb44f4372f
--- /dev/null
+++ b/dev-scheme/guile-gcrypt/guile-gcrypt-0.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Guile bindings of libgcrypt"
+HOMEPAGE="https://notabug.org/cwebber/guile-gcrypt"
+SRC_URI="https://notabug.org/cwebber/guile-gcrypt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-scheme/guile-2.0.11:=
+ dev-libs/libgcrypt:0=
+"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ default
+
+ # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
+ find "${S}" -name "*.scm" -exec touch {} + || die
+
+ # upstream tag on top of source tree. has no autogenerated files
+ eautoreconf
+}