summaryrefslogtreecommitdiff
path: root/dev-tcltk/tcllib
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/tcllib')
-rw-r--r--dev-tcltk/tcllib/Manifest3
-rw-r--r--dev-tcltk/tcllib/files/tcllib-1.20-test.patch101
-rw-r--r--dev-tcltk/tcllib/tcllib-1.20.ebuild46
3 files changed, 150 insertions, 0 deletions
diff --git a/dev-tcltk/tcllib/Manifest b/dev-tcltk/tcllib/Manifest
index 92109e60b4bd..afb694c4d291 100644
--- a/dev-tcltk/tcllib/Manifest
+++ b/dev-tcltk/tcllib/Manifest
@@ -1,4 +1,7 @@
AUX tcllib-1.19-test.patch 501 BLAKE2B 141beca1582b3fef5a632ff807b86a437883de236ed54b6cbfa38a85b7a5e84b520502689d7b7f04aa4f32fedc3bdb8148162f98a53ea4f15668a69c26658a4d SHA512 b0b10dfade925201a4ea67f1da0c14fb8fa9f7fbad852f38e8263dfd323d3125d807fec10d02d4fced4d07997463a1815475707259a19f32380c7cb31cbdc614
+AUX tcllib-1.20-test.patch 5515 BLAKE2B 8048f7568d6651014c9153f4e5a26a1580f10ce510ce0eead2960bba732f9424faaeec4392af5b7647633d3946a8e290c5f33ea0b60f754358d7ef3eb07be1cc SHA512 494e60644baccb516c8b4847cf300b53630e222f34899d9d620e84d1573be0d0b3df69f9be5534416ae360460cd7ea3cd5e0f24d2124c00702449caa66752e69
DIST tcllib-1.19.tar.xz 6298564 BLAKE2B f137227004dd4acded7c8aae6b36fd50fedee67a725ecef0046f1af7abc7bb8e11207a141e15390a6ce3a1a3914b1cd2e5a798035eba631254792b2819383013 SHA512 08f549a3513316919c61f015a604aa671a73c0fd59a8a20b916d106e7d7d6f4bd59b485a92307778cfea1b00f78c2972a086b1bf960fe85a26fe273b7ada8d12
+DIST tcllib-1.20.tar.xz 6692664 BLAKE2B 3e70cf0d0f9e469a20e18f84238f56a53b5b8e36abcf418dc32f64c819728968d24e2999705d91d8341cb608a6bb674a063e86253cddfb51f2693a94d0e070e5 SHA512 d2c20642f91cdc7bf3b329025be80eb9288d0919fa439c2066349b52950cf3c343f39c7745b9b08ec28a884ff2f219fe0fb5f47023f1266b6a6de6ae54852412
EBUILD tcllib-1.19.ebuild 1219 BLAKE2B 6eae3d390eac5b17e5cd160b173f779098a02b05f44d3758d78cb226877f4a108dc7b7a2a69099318f4952983324dc3cb9cac6497410af64c7ff28ebb97e3c99 SHA512 5cfe773b4f81507db98941b1524e4fb30db393c6804d6f746e5c2db3a3e79e8e859c15e9b4dc1453d16ab97d90bb5dce2ed333bf1fb6e082630e6c83d88c20e4
+EBUILD tcllib-1.20.ebuild 916 BLAKE2B a5c846998de31966f19e328311360e14e3c224cb7dca8f6f343d6a4ef7c1151153040219887781a5dc6839ba1d07d1d091ca880f509411637e0e16b8df874bad SHA512 f19e8490c6933e868f0385bd4d5817d9f11840ce00123efe38aae3b60b00bc3f762aaafe3dbd451cc2e8d0bf6b0dc1a81e3eda315343314ea0461923d30154ac
MISC metadata.xml 329 BLAKE2B 9c75c5b20f8ce9b566b4a422c4d768c3c2db1f593d8505ee7539932860f99ab5eeafb51d02e84d78f7be0c8be06e22fadb64aaf61cf01b7b14ac506035c70c79 SHA512 c16db3fedc73cc41391e15f198396908ebd047c165c2bbe3c465f126dfb8266818d79f11ec343a2880058850a8164801616632f361b69db914e7d66823bb1851
diff --git a/dev-tcltk/tcllib/files/tcllib-1.20-test.patch b/dev-tcltk/tcllib/files/tcllib-1.20-test.patch
new file mode 100644
index 000000000000..80371c98115c
--- /dev/null
+++ b/dev-tcltk/tcllib/files/tcllib-1.20-test.patch
@@ -0,0 +1,101 @@
+--- a/modules/devtools/testutilities.tcl 2020-04-16 21:57:11.915653960 +0200
++++ b/modules/devtools/testutilities.tcl 2020-04-16 22:11:05.621829465 +0200
+@@ -229,6 +229,10 @@
+ ::tcltest::testConstraint tcl8.6plus \
+ [expr {[package vsatisfies [package provide Tcl] 8.6]}]
+
++ ::tcltest::testConstraint tcl8.6.8 \
++ [expr { [package vsatisfies [package provide Tcl] 8.6.8] &&
++ ![package vsatisfies [package provide Tcl] 8.6.9]}]
++
+ ::tcltest::testConstraint tcl8.6not10 \
+ [expr { [package vsatisfies [package provide Tcl] 8.6] &&
+ ![package vsatisfies [package provide Tcl] 8.6.10]}]
+--- a/modules/hook/hook.test 2020-04-16 21:59:22.708326030 +0200
++++ b/modules/hook/hook.test 2020-04-16 22:09:18.055740312 +0200
+@@ -436,6 +436,7 @@
+ } -cleanup {
+ cleanup
+ } -result [tcltest::byConstraint {
++ tcl8.6.8 {{{S1 <H1> {} O1} {simulated error} {-code 1 -level 0 -errorstack {INNER {error {simulated error}} UP 1 CALL {::hook::call S1 <H1>}} -errorcode NONE}}}
+ tcl8.6.10plus {{{S1 <H1> {} O1} {simulated error} {-code 1 -level 0 -errorstack {INNER {error {simulated error}} UP 1 CALL {::hook::call S1 <H1>}} -errorcode NONE}}}
+ tcl8.6not10 {{{S1 <H1> {} O1} {simulated error} {-code 1 -level 0 -errorstack {INNER {error {simulated error}} UP 1 CALL {call S1 <H1>}} -errorcode NONE}}}
+ tcl8.5minus {{{S1 <H1> {} O1} {simulated error} {-code 1 -level 0 -errorcode NONE}}}
+@@ -452,6 +453,7 @@
+ } -cleanup {
+ cleanup
+ } -result [tcltest::byConstraint {
++ tcl8.6.8 {{{S1 <H1> O1 {}} {S1 <H1> O3 {}}} {{{S1 <H1> {} O2} {simulated error} {-code 1 -level 0 -errorstack {INNER {error {simulated error}} UP 1 CALL {::hook::call S1 <H1>}} -errorcode NONE}}}}
+ tcl8.6.10plus {{{S1 <H1> O1 {}} {S1 <H1> O3 {}}} {{{S1 <H1> {} O2} {simulated error} {-code 1 -level 0 -errorstack {INNER {error {simulated error}} UP 1 CALL {::hook::call S1 <H1>}} -errorcode NONE}}}}
+ tcl8.6not10 {{{S1 <H1> O1 {}} {S1 <H1> O3 {}}} {{{S1 <H1> {} O2} {simulated error} {-code 1 -level 0 -errorstack {INNER {error {simulated error}} UP 1 CALL {call S1 <H1>}} -errorcode NONE}}}}
+ tcl8.5minus {{{S1 <H1> O1 {}} {S1 <H1> O3 {}}} {{{S1 <H1> {} O2} {simulated error} {-code 1 -level 0 -errorcode NONE}}}}
+--- a/modules/http/autoproxy.test 2020-04-16 22:48:04.645153193 +0200
++++ b/modules/http/autoproxy.test 2020-04-16 22:48:30.710701582 +0200
+@@ -179,20 +179,6 @@
+ autoproxy::configure -tls_package dummy
+ } -result "Invalid TLS package option 'dummy'. Must be 'tls' or 'twapi'" -returnCodes error
+
+-test autoproxy-2.0.0 "autoproxy::tls_socket (tls) with proxy" -constraints {
+- have_tls
+-} -setup {
+- packageReset
+- package require http
+- autoproxy::configure -proxy_host $proxy_host -proxy_port $proxy_port
+-} -body {
+- http::register https 443 autoproxy::tls_socket
+- set tok [http::geturl https://www.example.com]
+- http::status $tok
+-} -cleanup {
+- http::cleanup $tok
+-} -result ok
+-
+ test autoproxy-2.0.1 "autoproxy::tls_socket (twapi) with proxy" -constraints {
+ have_twapi
+ } -setup {
+@@ -202,20 +188,6 @@
+ } -body {
+ http::register https 443 autoproxy::tls_socket
+ set tok [http::geturl https://www.example.com]
+- http::status $tok
+-} -cleanup {
+- http::cleanup $tok
+-} -result ok
+-
+-test autoproxy-2.1.0 "autoproxy::tls_socket (tls) without proxy" -constraints {
+- have_tls
+-} -setup {
+- packageReset
+- package require http
+- autoproxy::configure -proxy_host "" -proxy_port $proxy_port
+-} -body {
+- http::register https 443 autoproxy::tls_socket
+- set tok [http::geturl https://www.example.com]
+ http::status $tok
+ } -cleanup {
+ http::cleanup $tok
+--- a/modules/string/token_shell.test 2020-04-17 08:40:44.813030086 +0200
++++ b/modules/string/token_shell.test 2020-04-17 08:44:03.066752545 +0200
+@@ -26,6 +26,7 @@
+ test string-token-shell-1.0 "string token shell, wrong#args, not enough" -body {
+ string token shell
+ } -returnCodes error -result [tcltest::byConstraint {
++ tcl8.6.8 {wrong # args: should be "::string::token::shell ?-indices? ?-partial? ?--? text"}
+ tcl8.6.10plus {wrong # args: should be "::string::token::shell ?-indices? ?-partial? ?--? text"}
+ tcl8.6not10 {wrong # args: should be "shell ?-indices? ?-partial? ?--? text"}
+ tcl8.5minus {wrong # args: should be "::string::token::shell ?-indices? ?-partial? ?--? text"}
+@@ -34,6 +35,7 @@
+ test string-token-shell-1.1 "string token shell, wrong#args, too many" -body {
+ string token shell T X
+ } -returnCodes error -result [tcltest::byConstraint {
++ tcl8.6.8 {wrong # args: should be "::string::token::shell ?-indices? ?-partial? ?--? text"}
+ tcl8.6.10plus {wrong # args: should be "::string::token::shell ?-indices? ?-partial? ?--? text"}
+ tcl8.6not10 {wrong # args: should be "shell ?-indices? ?-partial? ?--? text"}
+ tcl8.5minus {wrong # args: should be "::string::token::shell ?-indices? ?-partial? ?--? text"}
+@@ -46,6 +48,7 @@
+ test string-token-shell-1.3 "string token shell, wrong#args, too many" -body {
+ string token shell -- T X
+ } -returnCodes error -result [tcltest::byConstraint {
++ tcl8.6.8 {wrong # args: should be "::string::token::shell ?-indices? ?-partial? ?--? text"}
+ tcl8.6.10plus {wrong # args: should be "::string::token::shell ?-indices? ?-partial? ?--? text"}
+ tcl8.6not10 {wrong # args: should be "shell ?-indices? ?-partial? ?--? text"}
+ tcl8.5minus {wrong # args: should be "::string::token::shell ?-indices? ?-partial? ?--? text"}
diff --git a/dev-tcltk/tcllib/tcllib-1.20.ebuild b/dev-tcltk/tcllib/tcllib-1.20.ebuild
new file mode 100644
index 000000000000..54cb1d43047c
--- /dev/null
+++ b/dev-tcltk/tcllib/tcllib-1.20.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit virtualx
+
+DESCRIPTION="Tcl Standard Library"
+HOMEPAGE="http://www.tcl.tk/software/tcllib/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${PV}/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="examples"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-lang/tcl:0=
+ dev-tcltk/tdom
+ "
+DEPEND="${RDEPEND}"
+
+DOCS=(
+ ChangeLog DESCRIPTION.txt README.md devdoc/README.developer
+ devdoc/critcl-tcllib.txt devdoc/dirlayout_install.txt
+ devdoc/indexing.txt
+)
+HTML_DOCS=( idoc/www )
+
+PATCHES=( "${FILESDIR}"/${P}-test.patch )
+
+src_test() {
+ USER= virtx emake test_batch
+}
+
+src_install() {
+ default
+
+ if use examples ; then
+ for f in $(find examples -type f); do
+ docinto $(dirname $f)
+ dodoc $f
+ done
+ fi
+}