summaryrefslogtreecommitdiff
path: root/dev-tex/currvita/currvita-0.9i-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/currvita/currvita-0.9i-r1.ebuild')
-rw-r--r--dev-tex/currvita/currvita-0.9i-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-tex/currvita/currvita-0.9i-r1.ebuild b/dev-tex/currvita/currvita-0.9i-r1.ebuild
new file mode 100644
index 000000000000..8bfbea765806
--- /dev/null
+++ b/dev-tex/currvita/currvita-0.9i-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit latex-package
+
+DESCRIPTION="A LaTeX package for typesetting a curriculum vitae"
+HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/currvita/"
+# snapshot taken from
+# ftp://ftp.dante.de/tex-archive/macros/latex/contrib/currvita.tar.gz
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+IUSE=""
+
+DEPEND="dev-texlive/texlive-langgerman"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+TEXMF="/usr/share/texmf-site"
+DOCS="README"
+
+src_test() {
+ latex currvita.dtx || die "first step of currvita.dtx failed"
+ latex currvita.dtx || die "second step of currvita.dtx failed"
+ latex currvita.dtx || die "third step of currvita.dtx failed"
+ latex cvtest.tex || die "processing cvtest.tex failed"
+}