summaryrefslogtreecommitdiff
path: root/dev-tex/curve/curve-1.16-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/curve/curve-1.16-r1.ebuild')
-rw-r--r--dev-tex/curve/curve-1.16-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-tex/curve/curve-1.16-r1.ebuild b/dev-tex/curve/curve-1.16-r1.ebuild
new file mode 100644
index 000000000000..fd710c2dbb9c
--- /dev/null
+++ b/dev-tex/curve/curve-1.16-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit latex-package
+
+DESCRIPTION="LaTeX style for a CV (curriculum vitae) with flavour option"
+HOMEPAGE="https://ctan.org/tex-archive/macros/latex/contrib/curve/"
+SRC_URI="http://mirrors.ctan.org/macros/latex/contrib/${PN}.zip -> ${P}.zip"
+
+LICENSE="LPPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc examples"
+
+RDEPEND=">=dev-texlive/texlive-latexextra-2010"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+TEXMF=/usr/share/texmf-site
+
+src_install() {
+ dodoc README NEWS THANKS
+
+ latex-package_src_doinstall styles
+
+ if use doc ; then
+ latex-package_src_doinstall pdf
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/example
+ doins examples/*
+ fi
+}