summaryrefslogtreecommitdiff
path: root/dev-tex/dot2tex
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/dot2tex')
-rw-r--r--dev-tex/dot2tex/Manifest3
-rw-r--r--dev-tex/dot2tex/dot2tex-2.9.0.ebuild43
-rw-r--r--dev-tex/dot2tex/metadata.xml12
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-tex/dot2tex/Manifest b/dev-tex/dot2tex/Manifest
new file mode 100644
index 000000000000..3b2ebd3b23ee
--- /dev/null
+++ b/dev-tex/dot2tex/Manifest
@@ -0,0 +1,3 @@
+DIST dot2tex-2.9.0.tar.gz 663372 BLAKE2B 807093c5bd7304a6c315568e69c8c8387a377a8aa47790d558feb84036ca6ce2d00534823254a50af9852206d0e27b2e15f2a8ba0e8333e2bb8b20a983947e74 SHA512 97ba9983643254d5a3034d2fc8c454c445849ac546bd285676b854e20c8aae9a25d61e73632717da1562541ce9b3a4ae8aa4daa29e33f78105e28a34b5ebae5d
+EBUILD dot2tex-2.9.0.ebuild 1014 BLAKE2B 5fbafc4b682f7142c2a68d72f8182d19c40c4d140af4c60971b5b2e6f13259bbd8f09b1839edc9e06d1bb06a073ed49a119eaf4dad7889b63e882c3c84f5eb79 SHA512 c20fc0c894ba9c4e9ccbbb44bf3c13905726d9e470de1a8efa7eae9ff2a82d84fc225f9eaf1b6cf63f9f639180eeefaf52e6d986e8bdf47039dbd9d6cf5c48b1
+MISC metadata.xml 381 BLAKE2B ab936fa6e8bedf30df2713557cb55b558831dd2230be87fdea15ef84c7ded1a665b90d74cea23a3a2d4ff0bef03e43af9f226e1d236c5e5e79ebfb51a2b55358 SHA512 1b1e745b1979792a554d0a0fbd15e5f97f4806e668ccf3ddb519e60cf70af7081194f1f442b6cd7ef5ff4676fd2a837833e59879d4b05dff817927a11449700e
diff --git a/dev-tex/dot2tex/dot2tex-2.9.0.ebuild b/dev-tex/dot2tex/dot2tex-2.9.0.ebuild
new file mode 100644
index 000000000000..3baa221b33b2
--- /dev/null
+++ b/dev-tex/dot2tex/dot2tex-2.9.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Graphviz to LaTeX converter"
+HOMEPAGE="https://dot2tex.readthedocs.org/ https://github.com/kjellmf/dot2tex"
+SRC_URI="https://github.com/kjellmf/dot2tex/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="doc examples"
+
+DEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/pydot[${PYTHON_USEDEP}]
+ media-gfx/graphviz"
+DEPEND="${DEPEND}
+ doc? ( dev-python/sphinx )"
+
+python_compile_all() {
+ if use doc ; then
+ cd "${S}/docs"
+ emake html
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dohtml -r docs/_build/html/*
+ fi
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-tex/dot2tex/metadata.xml b/dev-tex/dot2tex/metadata.xml
new file mode 100644
index 000000000000..00f39352db81
--- /dev/null
+++ b/dev-tex/dot2tex/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>tex@gentoo.org</email>
+ <name>Gentoo TeX Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">dot2tex</remote-id>
+ <remote-id type="github">kjellmf/dot2tex</remote-id>
+ </upstream>
+</pkgmetadata>