summaryrefslogtreecommitdiff
path: root/dev-tex/hevea
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/hevea')
-rw-r--r--dev-tex/hevea/Manifest7
-rw-r--r--dev-tex/hevea/hevea-2.29.ebuild58
-rw-r--r--dev-tex/hevea/hevea-2.30.ebuild58
-rw-r--r--dev-tex/hevea/hevea-2.31.ebuild58
-rw-r--r--dev-tex/hevea/metadata.xml12
5 files changed, 193 insertions, 0 deletions
diff --git a/dev-tex/hevea/Manifest b/dev-tex/hevea/Manifest
new file mode 100644
index 000000000000..11a2e221afa6
--- /dev/null
+++ b/dev-tex/hevea/Manifest
@@ -0,0 +1,7 @@
+DIST hevea-2.29.tar.gz 969599 BLAKE2B 88724c0a1a139d370fa852af473e4f21f7c1f8a8ed79cf0a59fa6098d63a3956423f7b1403316aa2e296b00d77ddc529938f98476243795b6a00971532918d90 SHA512 4ea2f3d60fd43d183712a868cb3894b38f6d9809ba7905d69123a7672faba0d6dfe73ad1379d7996ede98ceb645bba903e5b7550bdf92e7950ce69ba7f4f3994
+DIST hevea-2.30.tar.gz 965635 BLAKE2B 7f23c6f793be1515b689571f0ae25d76d45c7bd8df9cc6fe1f73697b34dec598f64b0ed30e4b2cd5e456990c80ac0bba50c60e0294a825c6a0af59b228456cbd SHA512 75c700e009070bff4845ccc6f984ade8068f90ea78630a2e6ab1d27618a225a4bbbb7c4aa07c08be03094ddad4aac5d0c9e83fa01d41ff501f5c1eed9f4428eb
+DIST hevea-2.31.tar.gz 965678 BLAKE2B 770a3ff5b3e209d1e34e68647baffc064cb78f63a610e6b81181a829837861984f22e381cc17c34a3b0b4643c260a5cb84841cd8e2038e40083bba7ffbdab929 SHA512 4b66030f69b8b60750f8e62a9d81240b0ba399af8af69df10b33742e10d23fe7aef3e7782265fac9705f27715e5964debd47b9da7a394f70fda947b5fcd2d6ea
+EBUILD hevea-2.29.ebuild 1578 BLAKE2B 45718a3e4289fc79eb1a9be6bab4763dc2165097635902cbcecbd9fc30a461289778ae6e8ef7829b60fd9c1b484f131880a5d51db18ad18f6718e991c1344bb8 SHA512 6125faaaa52cd1cf0323ed91c06983538782a83618e21bcfda29ef27351f4173a9e1d252ff7381d1386f7e80e74ed97bb3a3e1b0f1a0371295d3dbed326a9ca9
+EBUILD hevea-2.30.ebuild 1582 BLAKE2B b25c3d4a2f596c3145d7e1772be6599be738c857e61537dd74478365db9a6e55d8e679a7feb237fa1e51d28011238f07faf2c05508705cc02c40b8c39673d09d SHA512 ec3d25692e4a81ab3f5421abbeed4711b87c83de22c464e34ee41bd803b543e97ba08eef7077c8c9b33790074925472df023399ab900b656e2f284a3cab67cb4
+EBUILD hevea-2.31.ebuild 1582 BLAKE2B b25c3d4a2f596c3145d7e1772be6599be738c857e61537dd74478365db9a6e55d8e679a7feb237fa1e51d28011238f07faf2c05508705cc02c40b8c39673d09d SHA512 ec3d25692e4a81ab3f5421abbeed4711b87c83de22c464e34ee41bd803b543e97ba08eef7077c8c9b33790074925472df023399ab900b656e2f284a3cab67cb4
+MISC metadata.xml 356 BLAKE2B a7f615933a0e3a96a715745ae427649370e382d38621d77733982247fd090942d75d9328b2274d7d636bde0a44822a6ca40f4a8f50cb4127f359ec674309068a SHA512 f01f19a40a296cd3675f75d2c09aae119bc9c644e7c80b3bebb8f265c5e49dc47f481b33e93aed51db6f19a6164b5cdff5cfabeb7e7daf10c67994cfa7aa1375
diff --git a/dev-tex/hevea/hevea-2.29.ebuild b/dev-tex/hevea/hevea-2.29.ebuild
new file mode 100644
index 000000000000..4eba8726f009
--- /dev/null
+++ b/dev-tex/hevea/hevea-2.29.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils multilib
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="HeVeA is a quite complete and fast LaTeX to HTML translator"
+HOMEPAGE="http://hevea.inria.fr/"
+SRC_URI="http://hevea.inria.fr/distri/${P}.tar.gz"
+
+LICENSE="QPL"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 sparc x86"
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]"
+RDEPEND="${DEPEND}
+ dev-texlive/texlive-latexextra"
+DEPEND="${DEPEND} dev-ml/ocamlbuild"
+
+src_compile() {
+ rm -f config.sh
+ emake PREFIX=/usr DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)/hevea" LATEXLIBDIR="/usr/share/texmf-site/tex/latex/hevea" config.sh || die "Failed to create config.sh"
+ if use ocamlopt; then
+ emake PREFIX=/usr || die "Failed to build native code binaries"
+ else
+ emake PREFIX=/usr TARGET=byte || die "Failed to build bytecode binaries"
+ fi
+}
+
+src_install() {
+ if use ocamlopt; then
+ emake DESTDIR="${D}" PREFIX=/usr install || die "Install failed"
+ else
+ emake DESTDIR="${D}" PREFIX=/usr TARGET=byte install || die "Install failed"
+ fi
+
+ dodoc README CHANGES
+}
+
+# If texmf-update is present this means we have a latex install; update it so
+# that hevea.sty can be found
+# Do not (r)depend on latex though because hevea does not need it itself
+# If latex is installed later, it will see hevea.sty
+
+pkg_postinst() {
+ if [ "$ROOT" = "/" ] && [ -x /usr/sbin/texmf-update ] ; then
+ /usr/sbin/texmf-update
+ fi
+}
+
+pkg_postrm() {
+ if [ "$ROOT" = "/" ] && [ -x /usr/sbin/texmf-update ] ; then
+ /usr/sbin/texmf-update
+ fi
+}
diff --git a/dev-tex/hevea/hevea-2.30.ebuild b/dev-tex/hevea/hevea-2.30.ebuild
new file mode 100644
index 000000000000..a09af4ace2c4
--- /dev/null
+++ b/dev-tex/hevea/hevea-2.30.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils multilib
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="HeVeA is a quite complete and fast LaTeX to HTML translator"
+HOMEPAGE="http://hevea.inria.fr/"
+SRC_URI="http://hevea.inria.fr/distri/${P}.tar.gz"
+
+LICENSE="QPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]"
+RDEPEND="${DEPEND}
+ dev-texlive/texlive-latexextra"
+DEPEND="${DEPEND} dev-ml/ocamlbuild"
+
+src_compile() {
+ rm -f config.sh
+ emake PREFIX=/usr DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)/hevea" LATEXLIBDIR="/usr/share/texmf-site/tex/latex/hevea" config.sh || die "Failed to create config.sh"
+ if use ocamlopt; then
+ emake PREFIX=/usr || die "Failed to build native code binaries"
+ else
+ emake PREFIX=/usr TARGET=byte || die "Failed to build bytecode binaries"
+ fi
+}
+
+src_install() {
+ if use ocamlopt; then
+ emake DESTDIR="${D}" PREFIX=/usr install || die "Install failed"
+ else
+ emake DESTDIR="${D}" PREFIX=/usr TARGET=byte install || die "Install failed"
+ fi
+
+ dodoc README CHANGES
+}
+
+# If texmf-update is present this means we have a latex install; update it so
+# that hevea.sty can be found
+# Do not (r)depend on latex though because hevea does not need it itself
+# If latex is installed later, it will see hevea.sty
+
+pkg_postinst() {
+ if [ "$ROOT" = "/" ] && [ -x /usr/sbin/texmf-update ] ; then
+ /usr/sbin/texmf-update
+ fi
+}
+
+pkg_postrm() {
+ if [ "$ROOT" = "/" ] && [ -x /usr/sbin/texmf-update ] ; then
+ /usr/sbin/texmf-update
+ fi
+}
diff --git a/dev-tex/hevea/hevea-2.31.ebuild b/dev-tex/hevea/hevea-2.31.ebuild
new file mode 100644
index 000000000000..a09af4ace2c4
--- /dev/null
+++ b/dev-tex/hevea/hevea-2.31.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils multilib
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="HeVeA is a quite complete and fast LaTeX to HTML translator"
+HOMEPAGE="http://hevea.inria.fr/"
+SRC_URI="http://hevea.inria.fr/distri/${P}.tar.gz"
+
+LICENSE="QPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]"
+RDEPEND="${DEPEND}
+ dev-texlive/texlive-latexextra"
+DEPEND="${DEPEND} dev-ml/ocamlbuild"
+
+src_compile() {
+ rm -f config.sh
+ emake PREFIX=/usr DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)/hevea" LATEXLIBDIR="/usr/share/texmf-site/tex/latex/hevea" config.sh || die "Failed to create config.sh"
+ if use ocamlopt; then
+ emake PREFIX=/usr || die "Failed to build native code binaries"
+ else
+ emake PREFIX=/usr TARGET=byte || die "Failed to build bytecode binaries"
+ fi
+}
+
+src_install() {
+ if use ocamlopt; then
+ emake DESTDIR="${D}" PREFIX=/usr install || die "Install failed"
+ else
+ emake DESTDIR="${D}" PREFIX=/usr TARGET=byte install || die "Install failed"
+ fi
+
+ dodoc README CHANGES
+}
+
+# If texmf-update is present this means we have a latex install; update it so
+# that hevea.sty can be found
+# Do not (r)depend on latex though because hevea does not need it itself
+# If latex is installed later, it will see hevea.sty
+
+pkg_postinst() {
+ if [ "$ROOT" = "/" ] && [ -x /usr/sbin/texmf-update ] ; then
+ /usr/sbin/texmf-update
+ fi
+}
+
+pkg_postrm() {
+ if [ "$ROOT" = "/" ] && [ -x /usr/sbin/texmf-update ] ; then
+ /usr/sbin/texmf-update
+ fi
+}
diff --git a/dev-tex/hevea/metadata.xml b/dev-tex/hevea/metadata.xml
new file mode 100644
index 000000000000..db7d550fd7b0
--- /dev/null
+++ b/dev-tex/hevea/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>tex@gentoo.org</email>
+ <name>Gentoo TeX Project</name>
+ </maintainer>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+</pkgmetadata>