summaryrefslogtreecommitdiff
path: root/dev-tex/quotchap
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/quotchap')
-rw-r--r--dev-tex/quotchap/Manifest3
-rw-r--r--dev-tex/quotchap/metadata.xml8
-rw-r--r--dev-tex/quotchap/quotchap-0.9f.ebuild27
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-tex/quotchap/Manifest b/dev-tex/quotchap/Manifest
new file mode 100644
index 000000000000..82c898fb8fdd
--- /dev/null
+++ b/dev-tex/quotchap/Manifest
@@ -0,0 +1,3 @@
+DIST quotchap-0.9f.zip 276748 BLAKE2B 4b5a13b1ddc83fd5c08e7835840d7e132bd5b84e96f261f9c7e44c69b02cba7865d69f3b5c7a977161d239c4186f1ff43ead4b31417eb2486ec286a9ca0688b4 SHA512 4dc999ac61633d37afd4db699084edbebfb633dc23823c8c90b7477470281a158db1197231d8aedf82b5e75d697aae80b8026be13c5d49490d0b8f171874a6fe
+EBUILD quotchap-0.9f.ebuild 663 BLAKE2B aac9b76100a912844bf96a4d410f6ec352604289d13fd87890a085b9108aae0191c0e43ba40ac2964d7decd868734014526db3bbfc38cf7f0f2b0fc1fe0344ab SHA512 0c38cf472959524e49a612934957285b0289c8c885e9a1b6571968491651f7d8c8bc604510e3368607656091b979fd42d7a8827b732fad5274773d78cb4c5795
+MISC metadata.xml 245 BLAKE2B ee3a163cfe0a4bc59c0dfb46f9ddb580e2d259b4d0e33cb4e684eb9e6d4b901bf97c6edd891f3b75a613a782f1b89318d0ee3ec9bee4e34c4441d9e8f4267678 SHA512 1653777623e2c15e1ce13229e396723b2cc9c214983e0f8592de98c01a31badc6c38c6735ed44f937d145883b43fb6f049af3eddb9ff96b18c96ccf8f67dd690
diff --git a/dev-tex/quotchap/metadata.xml b/dev-tex/quotchap/metadata.xml
new file mode 100644
index 000000000000..13170c3184d8
--- /dev/null
+++ b/dev-tex/quotchap/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>tex@gentoo.org</email>
+ <name>Gentoo TeX Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-tex/quotchap/quotchap-0.9f.ebuild b/dev-tex/quotchap/quotchap-0.9f.ebuild
new file mode 100644
index 000000000000..df6349267043
--- /dev/null
+++ b/dev-tex/quotchap/quotchap-0.9f.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=0
+
+inherit latex-package
+
+S=${WORKDIR}/quotchap
+
+DESCRIPTION="LaTeX package used to add quotes to chapters"
+# Taken from http://theory.uwinnipeg.ca/scripts/CTAN/macros/latex/contrib/quotchap.zip
+SRC_URI="mirror://gentoo/${P}.zip"
+HOMEPAGE="ftp://ftp.dante.de/tex-archive/help/Catalogue/entries/quotchap.html"
+LICENSE="LPPL-1.2"
+SLOT="0"
+KEYWORDS="x86 ppc ~amd64"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_install () {
+ export VARTEXFONTS="${T}/fonts"
+ latex-package_src_doinstall all
+ cd "${S}"
+ dodoc 00readme.txt document.pdf document.tex
+}