summaryrefslogtreecommitdiff
path: root/dev-tex/rubber
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/rubber')
-rw-r--r--dev-tex/rubber/Manifest4
-rw-r--r--dev-tex/rubber/metadata.xml7
-rw-r--r--dev-tex/rubber/rubber-1.6.0_alpha1.ebuild103
3 files changed, 112 insertions, 2 deletions
diff --git a/dev-tex/rubber/Manifest b/dev-tex/rubber/Manifest
index 88d33cfd58a6..edc87fd36eab 100644
--- a/dev-tex/rubber/Manifest
+++ b/dev-tex/rubber/Manifest
@@ -1,3 +1,5 @@
DIST rubber-1.5.1.tar.gz 111812 BLAKE2B 4d08527689d669e3ac8dd6e9050fc09766bfb46c53d9923ce10efc0aaf8a62a962cb2f1c27a0e7a19a9be96710edba923d93589d816aa22305eec33fd08aa08c SHA512 ba22eeddc24b4f9abf0bf087604a4261add648877ec558b766555de09538cd20c21c8cfd9731c1421540bb2479501dd6ed066346d250c6bc981529e31efacc40
+DIST rubber-1.6.0-alpha1.tar.bz2 97809 BLAKE2B f2b37c33b6d7ab105b2567ff0b70c5c11333dc76fd633005ae8e1ca36b91e5579a3f75d1c4312b343cffaeff74d65e1046642ea78738b6b1126d3b05b2534ec7 SHA512 7ccc367929c09e01ce8458de5b3e8596cbb549026e7a917a0959733ae63398e903dd3bbcb22493d46073771fb70049207036260104f24693c4a1736e0d534e67
EBUILD rubber-1.5.1.ebuild 650 BLAKE2B 0935a9dc36cbdf08fca1e28bf998905a068d7454cb5f685b53218d46ab560b62f4ba7177308b8eab89bf5b57a14699e8834c6c8ab1f78285409478494d37d0d4 SHA512 842b0edf6161efb8d07bd78e6cc1b2e2c236db32cecdefa8bafdbcac26994d2a8fce7326e3458a30804f668f81cbc1d8f8a1aa762574b52b06ea6043511cd477
-MISC metadata.xml 323 BLAKE2B 46540c17674230be613731fbca57ec01370930462c33976af5d00763468eaa70705959ab5d45312430cab731d33ca04f6d8f74788a94c5de7a7bdd9a977f860b SHA512 038fa245ced154fbe7876039c19b87f414d06db21c9b9114274c2ced4221217ffa52e4cafdde1283c00155a3d4249cd7cddbfbdf24122aa67c1ca0f330f9d517
+EBUILD rubber-1.6.0_alpha1.ebuild 2955 BLAKE2B fdcf391455053ec19d32d379222f921a15c98e68a5d7ff33f36e073e9156e825ae5893b87e3db071819e3b3cb8b8d93860789a880a8d8a5b14635d40d1fecd48 SHA512 5e76672b17ccd6cae3ca1e50c8aae089a89be18a1a725a8aa5cebbccddc4539a618c07e7ae66a0fe5f0586ee433ec9d1703c9f78132245f8ec4921e2980f8254
+MISC metadata.xml 465 BLAKE2B 35b98091bfc187b6f15ad025bb22f275d45529b7a2d48c06dfaa0adf14012f5f71240b0b3f03933d5682f29f7df633c45144af7a2d2a0256028119ab8105827d SHA512 5feb82c15cee579697323da6ebcf8c16ad82ccfcdbd006efd98067b18ba5a635e6e19b04bd8051296dd0fc82e91ceef707f6c4073d6b062f5b006871e6355903
diff --git a/dev-tex/rubber/metadata.xml b/dev-tex/rubber/metadata.xml
index 1181e55599e2..e6f72b434f14 100644
--- a/dev-tex/rubber/metadata.xml
+++ b/dev-tex/rubber/metadata.xml
@@ -1,11 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person">
+ <email>flo@geekplace.eu</email>
+ <name>Florian Schmaus</name>
+ </maintainer>
<maintainer type="project">
<email>tex@gentoo.org</email>
<name>Gentoo TeX Project</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
- <remote-id type="launchpad">rubber</remote-id>
+ <remote-id type="gitlab">latex-rubber/rubber</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-tex/rubber/rubber-1.6.0_alpha1.ebuild b/dev-tex/rubber/rubber-1.6.0_alpha1.ebuild
new file mode 100644
index 000000000000..725038bd3ae3
--- /dev/null
+++ b/dev-tex/rubber/rubber-1.6.0_alpha1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS="no"
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] || [[ -n "${EGIT_COMMIT_ID}" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/latex-rubber/${PN}.git"
+else
+ UPSTREAM_PV=$(ver_rs 3 -)
+ SRC_URI="https://gitlab.com/latex-rubber/${PN}/-/archive/${UPSTREAM_PV}/${PN}-${UPSTREAM_PV}.tar.bz2"
+ S="${WORKDIR}/${PN}-${UPSTREAM_PV}"
+ KEYWORDS="~amd64 ~ppc ~x86"
+fi
+
+DESCRIPTION="A LaTeX wrapper for automatically building documents"
+HOMEPAGE="https://gitlab.com/latex-rubber/rubber"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="virtual/latex-base"
+
+# Test dependencies:
+# - app-text/texlive-core for rubber's 'cweave' test
+# - dev-lang/R for rubber's 'knitr' test (requires knitr R library, currently disabled)
+# - dev-texlive/texlive-latexextra for rubber's 'combine' test (currently disabled)
+BDEPEND="
+ ${RDEPEND}
+ virtual/texi2dvi
+ test? (
+ app-text/ghostscript-gpl
+ app-text/texlive-core
+ dev-tex/biber
+ dev-tex/biblatex
+ dev-tex/glossaries
+ dev-tex/latex-beamer
+ $(python_gen_cond_dep 'dev-tex/pythontex[${PYTHON_USEDEP}]')
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-pstricks
+ media-gfx/asymptote
+ )
+"
+
+python_test() {
+ cd tests || die
+
+ # Disable the broken 'combine' test as it uses the 'combine' as a
+ # latex package when it is only a document class (probably only in
+ # newer versions of combine). Also note that this tests works
+ # under debian 'buster'. TODO: Look into potential modifications
+ # done by debian.
+ touch combine/disable || die
+
+ # This test does not work under Gentoo nor Debian 'buster'.
+ # TODO: Investigate why it does not work.
+ touch cweb-latex/disable || die
+
+ # TODO: Investigate why the following are failing.
+ touch fig2dev-dvi/disable || die
+ touch fig2dev-path/disable || die
+ touch fig2dev-path-inplace/disable || die
+ touch fig2dev-path-into/disable || die
+ touch graphicx-dotted-files/disable || die
+ touch hooks-input-file/disable || die
+ touch knitr/disable || die
+
+ # Even tough metapost is available, those tests fail on Gentoo
+ # (while they succeed on Debian 'buster').
+ # TODO: Determine why.
+ # ERROR:mpost:I can't read MetaPost's log file, this is wrong.
+ touch metapost/disable || die
+ # expected error message not reported by Rubber
+ touch metapost-error/disable || die
+ # ERROR:mpost:I can't read MetaPost's log file, this is wrong.
+ touch metapost-input/disable || die
+
+ ./run.sh * || die "Tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ local my_install_args=(
+ --mandir="${EPREFIX}/usr/share/man"
+ --infodir="${EPREFIX}/usr/share/info"
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ )
+
+ distutils-r1_python_install "${my_install_args[@]}"
+}
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ newins misc/zsh-completion _rubber
+
+ distutils-r1_src_install
+}