summaryrefslogtreecommitdiff
path: root/dev-tex/tth/tth-3.77.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/tth/tth-3.77.ebuild')
-rw-r--r--dev-tex/tth/tth-3.77.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-tex/tth/tth-3.77.ebuild b/dev-tex/tth/tth-3.77.ebuild
new file mode 100644
index 000000000000..e3d52deb4f65
--- /dev/null
+++ b/dev-tex/tth/tth-3.77.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Translate TEX into HTML"
+HOMEPAGE="http://hutchinson.belmont.ma.us/tth/"
+SRC_URI="mirror://gentoo/${P}.tgz"
+
+SLOT="0"
+LICENSE="free-noncomm"
+KEYWORDS="amd64 ~arm hppa ppc ppc64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+
+S="${WORKDIR}/tth_C"
+
+src_compile() {
+ echo 'all: tth' > Makefile || die
+ tc-export CC
+ emake
+}
+
+src_install() {
+ dobin tth latex2gif ps2gif ps2png
+ dodoc CHANGES
+ doman tth.1
+ dohtml *
+}