summaryrefslogtreecommitdiff
path: root/dev-tex/tth/tth-4.08.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tex/tth/tth-4.08.ebuild')
-rw-r--r--dev-tex/tth/tth-4.08.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-tex/tth/tth-4.08.ebuild b/dev-tex/tth/tth-4.08.ebuild
new file mode 100644
index 000000000000..52dd9294de8e
--- /dev/null
+++ b/dev-tex/tth/tth-4.08.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Translate TEX into HTML"
+HOMEPAGE="http://hutchinson.belmont.ma.us/tth/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ emake GCC="$(tc-getCC) -O" tth
+ cd tools
+ tc-export CC
+ echo 'all: tthsplit' > makefile
+ emake
+}
+
+src_install() {
+ dobin tth latex2gif ps2gif tools/ps2png tools/tthsplit
+ dodoc CHANGES
+ doman tth.1
+}