summaryrefslogtreecommitdiff
path: root/dev-util/android-studio
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/android-studio')
-rw-r--r--dev-util/android-studio/Manifest2
-rw-r--r--dev-util/android-studio/android-studio-2024.1.2.13.ebuild122
2 files changed, 124 insertions, 0 deletions
diff --git a/dev-util/android-studio/Manifest b/dev-util/android-studio/Manifest
index 7e0f1c8595a0..3ba3ab405daf 100644
--- a/dev-util/android-studio/Manifest
+++ b/dev-util/android-studio/Manifest
@@ -1,3 +1,5 @@
DIST android-studio-2023.1.1.22-linux.tar.gz 1153989524 BLAKE2B 4dfd857543018c8a4584c4e2fff557d243a757ebe5974e915b3ea73a2a163fdb022e9e2bebc7a40ead74b6f2dccdd65a0bd796f45ffc43b598688d66533bb459 SHA512 f60495cc27cb70d240d8cf5f2c26009b50f91a75b807a53ee95f23dc8753cf569ed429ab351b7d64e8bf3b80c132e17a4ee2ee89602c4b564503cecf042a0297
+DIST android-studio-2024.1.2.13-linux.tar.gz 1236270079 BLAKE2B df145896887ac8a9cfe84172fbd097fdf4473eec04f829235b2e10773097441e752826afaabf715418d8de45ef007522833ab2a72c7f30770cce3f508b51300f SHA512 fd28fcbe11acabf6035ffebc861dde3c4dcb741f4d8bf067980762d0efb401303766a9b79c854c087e3772f76aca200332aa3f6eccf51543ddbc21a00dab3f88
EBUILD android-studio-2023.1.1.22-r1.ebuild 4329 BLAKE2B 21d12a2f112828cf36ba33d1f58cdc0d2def5a1002b21fc76ed8bc9a93483303e8f8e96b37a825bdd835037e2cbad095c235f1f580d0b791f036626495c5149a SHA512 118f1d785a025556ff64afc38e67ad6b38721840935ff9e30ddaa392bd8748cbc1d29d0d46122a334906f84a6d1ddacc172eec6e60793a046fb67ed7be70b7bf
+EBUILD android-studio-2024.1.2.13.ebuild 4356 BLAKE2B 5e187be7b5237c28c53b1d9a05ba2cf098fe835ccc7f151ef800aaea388a92dc00609687a5d0fbe5875f27e9238d64165573d13f29df7be460314fad7ea9975e SHA512 e2449c9f7b9318961f47f5cc3477f923da017c4c99f0c5c1f046359ae1a238258076c66d912668657433711318acf46e9ac248f987966658af1a020ad16e575b
MISC metadata.xml 298 BLAKE2B 8f13e01e8c5a24c9af764e8882e2d5677ebf485cad143f35720ede0d491f2c09fd009ce48433cd33f863fb618d6413eac97e07a6d3526f5c8e679d9e51995908 SHA512 2c9d3c5d14e2499fac58df1d3cb2844172833f371fe4d557791efc0848b879191bca36aa772792cea6edd8f6e3be83452a188c0db043906a46c87af0dcacd4e2
diff --git a/dev-util/android-studio/android-studio-2024.1.2.13.ebuild b/dev-util/android-studio/android-studio-2024.1.2.13.ebuild
new file mode 100644
index 000000000000..836e5a4556d1
--- /dev/null
+++ b/dev-util/android-studio/android-studio-2024.1.2.13.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop wrapper
+
+QA_PREBUILT="
+ opt/${PN}/bin/*
+ opt/${PN}/jbr/bin/*
+ opt/${PN}/jbr/lib/*
+ opt/${PN}/jbr/lib/jli/*
+ opt/${PN}/jbr/lib/server/*
+ opt/${PN}/lib/pty4j-native/linux/*/*
+ opt/${PN}/plugins/android/resources/installer/*/*
+ opt/${PN}/plugins/android/resources/native/*
+ opt/${PN}/plugins/android/resources/perfetto/*/*
+ opt/${PN}/plugins/android/resources/screen-sharing-agent/*/*
+ opt/${PN}/plugins/android/resources/simpleperf/*/*
+ opt/${PN}/plugins/android/resources/trace_processor_daemon/*
+ opt/${PN}/plugins/android/resources/transport/*/*
+ opt/${PN}/plugins/android/resources/transport/native/agent/*/*
+ opt/${PN}/plugins/android-ndk/resources/lldb/android/*/*
+ opt/${PN}/plugins/android-ndk/resources/lldb/bin/*
+ opt/${PN}/plugins/android-ndk/resources/lldb/lib/python3.9/lib-dynload/*
+ opt/${PN}/plugins/android-ndk/resources/lldb/lib64/*
+ opt/${PN}/plugins/design-tools/resources/layoutlib/data/linux/lib64/*
+ opt/${PN}/plugins/c-clangd/bin/clang/linux/*/*
+ opt/${PN}/plugins/webp/lib/libwebp/linux/*
+"
+
+DESCRIPTION="Android development environment based on IntelliJ IDEA"
+HOMEPAGE="https://developer.android.com/studio"
+SRC_URI="https://redirector.gvt1.com/edgedl/android/studio/ide-zips/${PV}/${P}-linux.tar.gz"
+S=${WORKDIR}/${PN}
+LICENSE="Apache-2.0 android BSD BSD-2 CDDL-1.1 CPL-0.5
+ EPL-1.0 GPL-2 GPL-2+ JDOM IJG LGPL-2.1 MIT
+ MPL-1.1 MPL-2.0 NPL-1.1 OFL-1.1 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="selinux"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-android )
+ >=app-arch/bzip2-1.0.8-r4
+ >=dev-libs/expat-2.5.0
+ >=dev-libs/libffi-3.4.4
+ >=media-libs/fontconfig-2.14.0-r1
+ >=media-libs/freetype-2.12.1-r1
+ >=media-libs/libpng-1.6.39
+ >=media-libs/mesa-22.2.5[X(+)]
+ || ( gnome-extra/zenity kde-apps/kdialog x11-apps/xmessage x11-libs/libnotify )
+ sys-libs/ncurses-compat:5[tinfo]
+ >=sys-libs/zlib-1.2.13-r1
+ >=x11-libs/libX11-1.8.1
+ >=x11-libs/libXau-1.0.11
+ >=x11-libs/libXdamage-1.1.6
+ >=x11-libs/libXdmcp-1.1.4-r2
+ >=x11-libs/libXext-1.3.5
+ >=x11-libs/libXfixes-6.0.0
+ >=x11-libs/libXrender-0.9.11
+ >=x11-libs/libXxf86vm-1.1.5
+ >=x11-libs/libdrm-2.4.114
+ >=x11-libs/libxcb-1.15-r1
+ >=x11-libs/libxshmfence-1.3.2
+ virtual/libcrypt:=
+"
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ local dir="/opt/${PN}"
+ insinto "${dir}"
+ doins -r *
+
+ fperms 755 "${dir}"/bin/{fsnotifier,format.sh,game-tools.sh,inspect.sh,ltedit.sh,profiler.sh,studio.sh,studio_safe.sh}
+ fperms -R 755 "${dir}"/bin/{helpers,lldb}
+ fperms -R 755 "${dir}"/jbr/bin
+ fperms 755 "${dir}"/jbr/lib/{jexec,jspawnhelper}
+ fperms -R 755 "${dir}"/plugins/Kotlin/kotlinc/bin
+ fperms -R 755 "${dir}"/plugins/android/resources/installer
+ fperms -R 755 "${dir}"/plugins/android/resources/perfetto
+ fperms -R 755 "${dir}"/plugins/android/resources/simpleperf
+ fperms -R 755 "${dir}"/plugins/android/resources/trace_processor_daemon
+ fperms -R 755 "${dir}"/plugins/android/resources/transport/{arm64-v8a,armeabi-v7a,x86,x86_64}
+ fperms -R 755 "${dir}"/plugins/android-ndk/resources/lldb/{android,bin,lib,shared}
+ fperms 755 "${dir}"/plugins/c-clangd-plugin/bin/clang/linux/x64/clangd
+ fperms -R 755 "${dir}"/plugins/terminal/shell-integrations/{,fish}
+
+ newicon "bin/studio.png" "${PN}.png"
+ make_wrapper ${PN} ${dir}/bin/studio.sh
+ make_desktop_entry ${PN} "Android Studio" ${PN} "Development;IDE" "StartupWMClass=jetbrains-studio"
+
+ # https://developer.android.com/studio/command-line/variables
+ newenvd - 99android-studio <<-EOF
+ # Configuration file android-studio
+ STUDIO_JDK="${dir}/jbr"
+ EOF
+
+ # recommended by: https://confluence.jetbrains.com/display/IDEADEV/Inotify+Watches+Limit
+ mkdir -p "${D}/etc/sysctl.d/" || die
+ echo "fs.inotify.max_user_watches = 524288" > "${D}/etc/sysctl.d/30-android-studio-inotify-watches.conf" || die
+}
+
+pkg_postrm() {
+ elog "Android Studio data files were not removed."
+ elog "If there will be no other programs using them anymore"
+ elog "(especially another flavor of Android Studio)"
+ elog "remove manually following folders:"
+ elog ""
+ elog " ~/.android/"
+ elog " ~/.config/Google/AndroidStudio*/"
+ elog " ~/.local/share/Google/AndroidStudio*/"
+ elog " ~/Android/"
+ elog ""
+ elog "Also, if there are no other programs using Gradle, remove:"
+ elog ""
+ elog " ~/.gradle/"
+}