summaryrefslogtreecommitdiff
path: root/dev-util/anjuta/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/anjuta/files')
-rw-r--r--dev-util/anjuta/files/3.34.0-Add-new-vala-support.patch132
-rw-r--r--dev-util/anjuta/files/3.34.0-autoconf-2.70.patch15
-rw-r--r--dev-util/anjuta/files/3.34.0-minimal.patch88
-rw-r--r--dev-util/anjuta/files/3.34.0-prefer-newer-vala.patch15
4 files changed, 88 insertions, 162 deletions
diff --git a/dev-util/anjuta/files/3.34.0-Add-new-vala-support.patch b/dev-util/anjuta/files/3.34.0-Add-new-vala-support.patch
deleted file mode 100644
index 219a0308121b..000000000000
--- a/dev-util/anjuta/files/3.34.0-Add-new-vala-support.patch
+++ /dev/null
@@ -1,132 +0,0 @@
-This is a combination of 7 upstream commits:
-
-build: Allow building with vala 0.46 and drop support for 0.30 and earlier
-language-support-vala: Support for vala 0.48 API
-build: Allow building with vala 0.48
-build: Allow building with vala 0.50
-build: Allow building with vala 0.50 and 0.52
-build: Allow building with vala 0.54
-build: Allow building with vala 0.56
----
- configure.ac | 4 +--
- plugins/language-support-vala/plugin.vala | 37 ++++++++++++++++++-----
- 2 files changed, 31 insertions(+), 10 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 3b4c99504..4fbad5392 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -338,7 +338,7 @@ if test "$user_disabled_vala" = 1; then
- else
- AC_MSG_RESULT(no)
- AC_MSG_CHECKING(if libvala is available)
-- m4_foreach([VERSION], [[0.44], [0.42], [0.40], [0.38], [0.36], [0.34], [0.32], [0.30], [0.28], [0.26], [0.24], [0.22], [0.20], [0.18]],
-+ m4_foreach_w([VERSION], [0.56 0.54 0.52 0.50 0.48 0.46 0.44 0.42 0.40 0.38 0.36 0.34 0.32],
- [PKG_CHECK_EXISTS([ libvala-VERSION ],
- [ valaver="-VERSION" ])
- ])
-@@ -350,7 +350,7 @@ else
- else
- AC_MSG_RESULT(no)
- enable_vala="no"
-- VALA_REQUIRED=0.18.0
-+ VALA_REQUIRED=0.32.0
- fi
- AC_SUBST(LIBVALA)
- fi
-diff --git a/plugins/language-support-vala/plugin.vala b/plugins/language-support-vala/plugin.vala
-index 13d35fec4..d94634c7f 100644
---- a/plugins/language-support-vala/plugin.vala
-+++ b/plugins/language-support-vala/plugin.vala
-@@ -78,7 +78,11 @@ public class ValaPlugin : Plugin, IAnjuta.Preferences {
-
- void init_context () {
- context = new Vala.CodeContext();
-+#if VALA_0_50
-+ context.set_target_profile (Vala.Profile.GOBJECT);
-+#else
- context.profile = Vala.Profile.GOBJECT;
-+#endif
- context.report = report;
- report.clear_error_indicators ();
-
-@@ -414,11 +418,19 @@ public class ValaPlugin : Plugin, IAnjuta.Preferences {
- builder.append_printf ("%s sender", widget.get_full_name ());
-
- foreach (var param in sig.get_parameters ()) {
-+#if VALA_0_48
-+ builder.append_printf (", %s %s", param.variable_type.type_symbol.get_full_name (), param.name);
-+#else
- builder.append_printf (", %s %s", param.variable_type.data_type.get_full_name (), param.name);
-+#endif
- }
- } else {
- foreach (var param in sig.get_parameters ()) {
-+#if VALA_0_48
-+ builder.append_printf ("%s %s, ", param.variable_type.type_symbol.get_full_name (), param.name);
-+#else
- builder.append_printf ("%s %s, ", param.variable_type.data_type.get_full_name (), param.name);
-+#endif
- }
-
- builder.append_printf ("%s sender", widget.get_full_name ());
-@@ -563,6 +575,15 @@ public class ValaPlugin : Plugin, IAnjuta.Preferences {
- }
- return matching_symbols;
- }
-+
-+ inline List<Vala.Symbol> symbol_lookup_inherited_for_type (Vala.DataType data_type, string name, bool prefix_match, bool invocation = false) {
-+#if VALA_0_48
-+ return symbol_lookup_inherited (data_type.type_symbol, name, prefix_match, invocation);
-+#else
-+ return symbol_lookup_inherited (data_type.data_type, name, prefix_match, invocation);
-+#endif
-+ }
-+
- List<Vala.Symbol> symbol_lookup_inherited (Vala.Symbol? sym, string name, bool prefix_match, bool invocation = false) {
- List<Vala.Symbol> result = null;
-
-@@ -580,32 +601,32 @@ public class ValaPlugin : Plugin, IAnjuta.Preferences {
- }
- if (invocation && sym is Vala.Method) {
- var func = (Vala.Method) sym;
-- result.concat (symbol_lookup_inherited (func.return_type.data_type, name, prefix_match));
-+ result.concat (symbol_lookup_inherited_for_type (func.return_type, name, prefix_match));
- } else if (sym is Vala.Class) {
- var cl = (Vala.Class) sym;
- foreach (var base_type in cl.get_base_types ()) {
-- result.concat (symbol_lookup_inherited (base_type.data_type, name, prefix_match));
-+ result.concat (symbol_lookup_inherited_for_type (base_type, name, prefix_match));
- }
- } else if (sym is Vala.Struct) {
- var st = (Vala.Struct) sym;
-- result.concat (symbol_lookup_inherited (st.base_type.data_type, name, prefix_match));
-+ result.concat (symbol_lookup_inherited_for_type (st.base_type, name, prefix_match));
- } else if (sym is Vala.Interface) {
- var iface = (Vala.Interface) sym;
- foreach (var prerequisite in iface.get_prerequisites ()) {
-- result.concat (symbol_lookup_inherited (prerequisite.data_type, name, prefix_match));
-+ result.concat (symbol_lookup_inherited_for_type (prerequisite, name, prefix_match));
- }
- } else if (sym is Vala.LocalVariable) {
- var variable = (Vala.LocalVariable) sym;
-- result.concat (symbol_lookup_inherited (variable.variable_type.data_type, name, prefix_match));
-+ result.concat (symbol_lookup_inherited_for_type (variable.variable_type, name, prefix_match));
- } else if (sym is Vala.Field) {
- var field = (Vala.Field) sym;
-- result.concat (symbol_lookup_inherited (field.variable_type.data_type, name, prefix_match));
-+ result.concat (symbol_lookup_inherited_for_type (field.variable_type, name, prefix_match));
- } else if (sym is Vala.Property) {
- var prop = (Vala.Property) sym;
-- result.concat (symbol_lookup_inherited (prop.property_type.data_type, name, prefix_match));
-+ result.concat (symbol_lookup_inherited_for_type (prop.property_type, name, prefix_match));
- } else if (sym is Vala.Parameter) {
- var fp = (Vala.Parameter) sym;
-- result.concat (symbol_lookup_inherited (fp.variable_type.data_type, name, prefix_match));
-+ result.concat (symbol_lookup_inherited_for_type (fp.variable_type, name, prefix_match));
- }
-
- return result;
---
-2.35.1
-
diff --git a/dev-util/anjuta/files/3.34.0-autoconf-2.70.patch b/dev-util/anjuta/files/3.34.0-autoconf-2.70.patch
deleted file mode 100644
index fdcc9e3158bf..000000000000
--- a/dev-util/anjuta/files/3.34.0-autoconf-2.70.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-https://gitlab.gnome.org/GNOME/anjuta/-/merge_requests/13
-
-diff --git a/configure.ac b/configure.ac
-index c637f9cf3..4b101c35e 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -85,8 +85,6 @@ case "$YACC" in
- AC_MSG_ERROR(bison is required)
- ;;
- esac
--AC_LANG([C])
--AC_LANG([C++])
- AC_PROG_CXX
- AC_LINK_IFELSE([AC_LANG_PROGRAM([], [])],,
- AC_MSG_ERROR([C++ Compiler required to compile Anjuta]))
diff --git a/dev-util/anjuta/files/3.34.0-minimal.patch b/dev-util/anjuta/files/3.34.0-minimal.patch
new file mode 100644
index 000000000000..3acd4c486b44
--- /dev/null
+++ b/dev-util/anjuta/files/3.34.0-minimal.patch
@@ -0,0 +1,88 @@
+Stubs out parts of configure not needed for the base library to avoid
+additional build dependencies. Some can be avoided by setting environment
+variables, but not all.
+
+-- Chewi
+
+diff -Naur a/configure b/configure
+--- a/configure 2019-09-08 19:32:47.000000000 +0100
++++ b/configure 2022-05-21 09:43:26.396618735 +0100
+@@ -4894,6 +4894,7 @@
+ ac_compiler_gnu=$ac_cv_c_compiler_gnu
+
+
++: <<'END'
+ for ac_prog in flex lex
+ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.
+@@ -5106,6 +5107,7 @@
+ as_fn_error $? "bison is required" "$LINENO" 5
+ ;;
+ esac
++END
+ ac_ext=c
+ ac_cpp='$CPP $CPPFLAGS'
+ ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
+@@ -17726,6 +17728,7 @@
+ fi
+
+
++: <<'END'
+ pkg_failed=no
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for GDA" >&5
+ $as_echo_n "checking for GDA... " >&6; }
+@@ -19533,6 +19536,7 @@
+ $as_echo "#define ENABLE_PACKAGEKIT 1" >>confdefs.h
+
+ fi
++END
+
+ LIBANJUTA_CFLAGS='$(ANJUTA_CFLAGS) $(GDL_CFLAGS) $(DEPRECATED_FLAGS) -I$(top_srcdir) -I$(top_builddir)/libanjuta -DPACKAGE_PIXMAPS_DIR=\""$(datadir)/pixmaps/$(PACKAGE)"\" -DPACKAGE_LIB_DIR=\""$(pkglibdir)"\" -DPACKAGE_DATA_DIR=\""$(datadir)/$(PACKAGE)"\"'
+ LIBANJUTA_LIBS='$(top_builddir)/libanjuta/libanjuta-3.la'
+@@ -19624,6 +19628,7 @@
+
+
+
++: <<'END'
+ case "$am__api_version" in
+ 1.01234)
+ as_fn_error $? "Automake 1.5 or newer is required to use intltool" "$LINENO" 5
+@@ -20441,6 +20446,7 @@
+
+
+ ac_config_commands="$ac_config_commands po-directories"
++END
+
+
+
+@@ -22459,6 +22465,7 @@
+
+
+
++: <<'END'
+ YELP_LC_MEDIA_LINKS=true
+ YELP_LC_DIST=true
+
+@@ -22738,6 +22745,7 @@
+ done; \
+ done;
+ '
++END
+
+
+
+@@ -24091,6 +24099,14 @@
+ am__EXEEXT_FALSE=
+ fi
+
++HAVE_PLUGIN_TERMINAL_TRUE='#'
++HAVE_PLUGIN_DEVHELP_TRUE='#'
++HAVE_PLUGIN_GLADE_TRUE='#'
++ENABLE_GLADE_CATALOG_TRUE='#'
++HAVE_SQLITE_TRUE='#'
++ENABLE_VALA_TRUE='#'
++HAVE_PYTHON_TRUE='#'
++
+ if test -z "${MAINTAINER_MODE_TRUE}" && test -z "${MAINTAINER_MODE_FALSE}"; then
+ as_fn_error $? "conditional \"MAINTAINER_MODE\" was never defined.
+ Usually this means the macro was only invoked conditionally." "$LINENO" 5
diff --git a/dev-util/anjuta/files/3.34.0-prefer-newer-vala.patch b/dev-util/anjuta/files/3.34.0-prefer-newer-vala.patch
deleted file mode 100644
index 6ae0ead0f3d7..000000000000
--- a/dev-util/anjuta/files/3.34.0-prefer-newer-vala.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-https://gitlab.gnome.org/GNOME/anjuta/-/merge_requests/14
-
-diff --git a/configure.ac b/configure.ac
-index c637f9cf3..b34e103b2 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -338,7 +338,7 @@ if test "$user_disabled_vala" = 1; then
- else
- AC_MSG_RESULT(no)
- AC_MSG_CHECKING(if libvala is available)
-- m4_foreach_w([VERSION], [0.56 0.54 0.52 0.50 0.48 0.46 0.44 0.42 0.40 0.38 0.36 0.34 0.32],
-+ m4_foreach_w([VERSION], [0.32 0.34 0.36 0.38 0.40 0.42 0.44 0.46 0.48 0.50 0.52 0.54 0.56],
- [PKG_CHECK_EXISTS([ libvala-VERSION ],
- [ valaver="-VERSION" ])
- ])