summaryrefslogtreecommitdiff
path: root/dev-util/ccache/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ccache/files')
-rw-r--r--dev-util/ccache/files/ccache-3.7.12-objdump.patch (renamed from dev-util/ccache/files/ccache-3.7.10-objdump.patch)7
-rw-r--r--dev-util/ccache/files/ccache-4.0-atomic.patch21
-rw-r--r--dev-util/ccache/files/ccache-4.0-avoid-run-user.patch18
-rw-r--r--dev-util/ccache/files/ccache-4.0-objdump.patch12
-rw-r--r--dev-util/ccache/files/ccache-4.1-avoid-run-user.patch18
5 files changed, 71 insertions, 5 deletions
diff --git a/dev-util/ccache/files/ccache-3.7.10-objdump.patch b/dev-util/ccache/files/ccache-3.7.12-objdump.patch
index bad334a5c546..f5387104e453 100644
--- a/dev-util/ccache/files/ccache-3.7.10-objdump.patch
+++ b/dev-util/ccache/files/ccache-3.7.12-objdump.patch
@@ -1,15 +1,12 @@
Allow ${CHOST}-objdump (or any other override)
--- a/test/suites/debug_prefix_map.bash
+++ b/test/suites/debug_prefix_map.bash
-@@ -24,9 +24,9 @@ objdump_cmd() {
+@@ -24,7 +24,7 @@ objdump_cmd() {
if $HOST_OS_APPLE; then
xcrun dwarfdump -r0 $1
- elif $HOST_OS_FREEBSD; then
+ else
- objdump -W $1
+ ${OBJDUMP-objdump} -W $1
- else
-- objdump -g $1
-+ ${OBJDUMP-objdump} -g $1
fi
}
diff --git a/dev-util/ccache/files/ccache-4.0-atomic.patch b/dev-util/ccache/files/ccache-4.0-atomic.patch
new file mode 100644
index 000000000000..87b237c7dd56
--- /dev/null
+++ b/dev-util/ccache/files/ccache-4.0-atomic.patch
@@ -0,0 +1,21 @@
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -63,11 +63,17 @@ if(WIN32)
+ endif()
+ endif()
+
++option(LINK_WITH_ATOMIC "Add 'atomic' if needed" OFF)
++set(atomic_lib "")
++if(LINK_WITH_ATOMIC)
++ set(atomic_lib "atomic")
++endif()
++
+ find_package(Threads REQUIRED)
+ target_link_libraries(
+ ccache_lib
+ PRIVATE standard_settings standard_warnings ZSTD::ZSTD
+- Threads::Threads third_party_lib)
++ Threads::Threads third_party_lib ${atomic_lib})
+
+ target_include_directories(ccache_lib PRIVATE ${CMAKE_BINARY_DIR} .)
+
diff --git a/dev-util/ccache/files/ccache-4.0-avoid-run-user.patch b/dev-util/ccache/files/ccache-4.0-avoid-run-user.patch
new file mode 100644
index 000000000000..07da25c6c341
--- /dev/null
+++ b/dev-util/ccache/files/ccache-4.0-avoid-run-user.patch
@@ -0,0 +1,18 @@
+Gentoo's sandbox does not whitelist this path by default yet.
+TODO: bug link.
+
+Until we have a sandbox whitelisting the path let's rely on ccache's default.
+--- a/src/Config.cpp
++++ b/src/Config.cpp
+@@ -833,11 +833,5 @@ Config::check_key_tables_consistency()
+ std::string
+ Config::default_temporary_dir(const std::string& cache_dir)
+ {
+-#ifdef HAVE_GETEUID
+- std::string user_tmp_dir = fmt::format("/run/user/{}", geteuid());
+- if (Stat::stat(user_tmp_dir).is_directory()) {
+- return user_tmp_dir + "/ccache-tmp";
+- }
+-#endif
+ return cache_dir + "/tmp";
+ }
diff --git a/dev-util/ccache/files/ccache-4.0-objdump.patch b/dev-util/ccache/files/ccache-4.0-objdump.patch
new file mode 100644
index 000000000000..af48e997f50b
--- /dev/null
+++ b/dev-util/ccache/files/ccache-4.0-objdump.patch
@@ -0,0 +1,12 @@
+Allow ${CHOST}-objdump (or any other override)
+--- a/test/run
++++ b/test/run
+@@ -133,7 +133,7 @@ objdump_cmd() {
+ # back to brute force and ignorance.
+ strings "$1"
+ else
+- objdump -W "$file"
++ ${OBJDUMP-objdump} -W "$file"
+ fi
+ }
+
diff --git a/dev-util/ccache/files/ccache-4.1-avoid-run-user.patch b/dev-util/ccache/files/ccache-4.1-avoid-run-user.patch
new file mode 100644
index 000000000000..be7db76ecbf0
--- /dev/null
+++ b/dev-util/ccache/files/ccache-4.1-avoid-run-user.patch
@@ -0,0 +1,18 @@
+Gentoo's sandbox does not whitelist this path by default yet.
+TODO: bug link.
+
+Until we have a sandbox whitelisting the path let's rely on ccache's default.
+--- a/src/Config.cpp
++++ b/src/Config.cpp
+@@ -885,11 +885,5 @@ Config::check_key_tables_consistency()
+ std::string
+ Config::default_temporary_dir(const std::string& cache_dir)
+ {
+-#ifdef HAVE_GETEUID
+- std::string user_tmp_dir = FMT("/run/user/{}", geteuid());
+- if (Stat::stat(user_tmp_dir).is_directory()) {
+- return user_tmp_dir + "/ccache-tmp";
+- }
+-#endif
+ return cache_dir + "/tmp";
+ }