summaryrefslogtreecommitdiff
path: root/dev-util/ccls
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ccls')
-rw-r--r--dev-util/ccls/Manifest4
-rw-r--r--dev-util/ccls/ccls-0.20240202.ebuild43
-rw-r--r--dev-util/ccls/ccls-9999.ebuild6
3 files changed, 49 insertions, 4 deletions
diff --git a/dev-util/ccls/Manifest b/dev-util/ccls/Manifest
index b078156f3eba..946ae64ee8a9 100644
--- a/dev-util/ccls/Manifest
+++ b/dev-util/ccls/Manifest
@@ -1,4 +1,6 @@
DIST ccls-0.20230717.tar.gz 161869 BLAKE2B fea3d484027d6b1493627e1bd3ea8f031b3486db7d41c34b94715a0abee342f0d87f85226ac567736013a71135325b3c9d13f6fe29b73db1b8dbc87586c16e1b SHA512 f0fe31877151b76cabc17aa2ef8d3d87038805fbe43ca807e2e0824e90d952b1f5767f151788480aedf58e2ff569b72978fceeaca6b741b00c643d73f6afb445
+DIST ccls-0.20240202.tar.gz 162283 BLAKE2B e96ae688690cfac13505e710c4b31afc5a3281bcb735d5f215b364870e0958b0b11799ab4340b74ef1530eb8d378d2b8dd7fddb1b16cbe5707073d63bce4a985 SHA512 bf30c869b985d7d6c0ecabfcc563b4983616c4f47ba743586a23441575695d87557113cdfd2603185adc454940d9244c331d9dc16444564358c910e2d61e9281
EBUILD ccls-0.20230717-r1.ebuild 902 BLAKE2B 591a2ef5a5c5e20b83c7623bb11663f6fe9486820170eb25b97c1f41b71f9e38942ee96aadbe07bd8ff2763da82a2a1e05ead7d3c8ae118290a0116ed45bc506 SHA512 bb25fa72cb7a812414c91cf37ddd5ac988acf040e3e7cf2a4fcafb3b7aac20a195e2d6e57b81dc15ffa867019d4415362ace9e53f417ae6583fa416ec7a2b9f3
-EBUILD ccls-9999.ebuild 903 BLAKE2B 555c64cd23259ee3451d5b3c3f1e22c983266066d58c2d32246486f0b136544815a05dd1e73ca9cbae1f26de057964b3f0371f620a16e033f4cc62c18f6c0f72 SHA512 84841641e179384e52e5369611d9b54ed794f49a7c917573cbe700d1fe6f33e946fc8e2c7e6fd436b14cdd0a6b3df333f44c5daf138f098a660817700665ac05
+EBUILD ccls-0.20240202.ebuild 903 BLAKE2B 04ee9d24877110aa22968785dadfb7d99267773dd7acbf9e2df3cb27f75ca7323ae2ad42863124b32e519696fddf1bff26515fde7cb02679cb8a96d7222b78a6 SHA512 f0c8f0a245d1b60a3d4458b3ab766192419a638d47c53a4893760c2e19861089176fbb564bb24a2c62d2e9fd24ebc1fbf5b88018238dde5890482c69ef994977
+EBUILD ccls-9999.ebuild 903 BLAKE2B 04ee9d24877110aa22968785dadfb7d99267773dd7acbf9e2df3cb27f75ca7323ae2ad42863124b32e519696fddf1bff26515fde7cb02679cb8a96d7222b78a6 SHA512 f0c8f0a245d1b60a3d4458b3ab766192419a638d47c53a4893760c2e19861089176fbb564bb24a2c62d2e9fd24ebc1fbf5b88018238dde5890482c69ef994977
MISC metadata.xml 324 BLAKE2B 83e4ab413a926db1ddf998ec8e5566a9a58fc2b3472b9d137356ebf3c08d4ca888a5252baeb0e10f298e31eca4bb4ea1a9b67c752590807be3ce27f8b3742327 SHA512 00dfaff2972f7ea5df02c207b8211475acafcbba5bef4c5ce3ceb09924db2bb3f009e155aab43866903e7442008d058261f07464f43f9295a4d1be6ed0cfec02
diff --git a/dev-util/ccls/ccls-0.20240202.ebuild b/dev-util/ccls/ccls-0.20240202.ebuild
new file mode 100644
index 000000000000..18afc3fd7cb3
--- /dev/null
+++ b/dev-util/ccls/ccls-0.20240202.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EGIT_REPO_URI="https://github.com/MaskRay/${PN}"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+ LLVM_MAX_SLOT=18
+else
+ LLVM_MAX_SLOT=18
+fi
+
+inherit cmake llvm ${GIT_ECLASS}
+
+DESCRIPTION="C/C++/ObjC language server"
+HOMEPAGE="https://github.com/MaskRay/ccls"
+
+if [[ ${PV} != *9999 ]] ; then
+ SRC_URI="https://github.com/MaskRay/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~riscv"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+# We only depend on Clang because of a quirk in how dependencies work
+# See comment in llvm.eclass docs
+DEPEND="
+ dev-libs/rapidjson
+ <sys-devel/clang-$((${LLVM_MAX_SLOT} + 1)):=
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCCLS_VERSION=${PV}
+ -DUSE_SYSTEM_RAPIDJSON=ON
+ -DCLANG_LINK_CLANG_DYLIB=1
+ )
+ cmake_src_configure
+}
diff --git a/dev-util/ccls/ccls-9999.ebuild b/dev-util/ccls/ccls-9999.ebuild
index ee7cfb7a7cf5..18afc3fd7cb3 100644
--- a/dev-util/ccls/ccls-9999.ebuild
+++ b/dev-util/ccls/ccls-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2023 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,9 +7,9 @@ EGIT_REPO_URI="https://github.com/MaskRay/${PN}"
if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
- LLVM_MAX_SLOT=17
+ LLVM_MAX_SLOT=18
else
- LLVM_MAX_SLOT=17
+ LLVM_MAX_SLOT=18
fi
inherit cmake llvm ${GIT_ECLASS}