summaryrefslogtreecommitdiff
path: root/dev-util/ccls
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ccls')
-rw-r--r--dev-util/ccls/Manifest3
-rw-r--r--dev-util/ccls/ccls-0.20240202.ebuild4
-rw-r--r--dev-util/ccls/files/ccls-0.20240202-gcc15-cstdint.patch22
3 files changed, 28 insertions, 1 deletions
diff --git a/dev-util/ccls/Manifest b/dev-util/ccls/Manifest
index e8797a4b295f..1ae8fbbc2f99 100644
--- a/dev-util/ccls/Manifest
+++ b/dev-util/ccls/Manifest
@@ -1,4 +1,5 @@
+AUX ccls-0.20240202-gcc15-cstdint.patch 612 BLAKE2B a1c979b30a6477e5b0785313ad67dfab3921ea7d70aba733be519ee7917fd77cc1a8f402db4d7b3b478d25357e1eec7bc9f7db454fef09c3b86e3bf3cbb9acd2 SHA512 46dd83941d7e8deae089f73deba03927b953fc07a4d8be7f699c51c88ff6a6ac7eaba80ac4bc450d56d0fe5131a2b10a8016187a870ed5b29fcc08b72d011240
DIST ccls-0.20240202.tar.gz 162283 BLAKE2B e96ae688690cfac13505e710c4b31afc5a3281bcb735d5f215b364870e0958b0b11799ab4340b74ef1530eb8d378d2b8dd7fddb1b16cbe5707073d63bce4a985 SHA512 bf30c869b985d7d6c0ecabfcc563b4983616c4f47ba743586a23441575695d87557113cdfd2603185adc454940d9244c331d9dc16444564358c910e2d61e9281
-EBUILD ccls-0.20240202.ebuild 902 BLAKE2B 574359f462818e85d36ac247fbe0440d6793d691e6b6a8488183ff3a52a87faf8d8bfc9d7c3719b70bea7bb4307f8e11ec7be0fdcbc22f146d5dd76e53d0ed90 SHA512 ec023757b92193166e13097be1fa51d80e39f5cc3f37cb8d4d00d1f1c460ae1ef9ab2bf6b10871d24ffc29f76ff582886eaa296ad8f4fe0d31a0b5f7149bec1d
+EBUILD ccls-0.20240202.ebuild 966 BLAKE2B edb93d9343609e640315de7798d3ee144003938de8dd2c7780e3a57d434f87febc9429ebe92c37be8d68eefbe3f3b5e74e34a43aabe450229e32d48f1f535d2d SHA512 4e2efc6beaad0817b8769346104ed694b82c5ca99e6863a35bb718845af69065d004106b27da261fa8d2ed797cf740f22e0416f6573bb042e2b335ea84d3b266
EBUILD ccls-9999.ebuild 903 BLAKE2B 04ee9d24877110aa22968785dadfb7d99267773dd7acbf9e2df3cb27f75ca7323ae2ad42863124b32e519696fddf1bff26515fde7cb02679cb8a96d7222b78a6 SHA512 f0c8f0a245d1b60a3d4458b3ab766192419a638d47c53a4893760c2e19861089176fbb564bb24a2c62d2e9fd24ebc1fbf5b88018238dde5890482c69ef994977
MISC metadata.xml 324 BLAKE2B 83e4ab413a926db1ddf998ec8e5566a9a58fc2b3472b9d137356ebf3c08d4ca888a5252baeb0e10f298e31eca4bb4ea1a9b67c752590807be3ce27f8b3742327 SHA512 00dfaff2972f7ea5df02c207b8211475acafcbba5bef4c5ce3ceb09924db2bb3f009e155aab43866903e7442008d058261f07464f43f9295a4d1be6ed0cfec02
diff --git a/dev-util/ccls/ccls-0.20240202.ebuild b/dev-util/ccls/ccls-0.20240202.ebuild
index 1cb54ca0aa66..d0c1c4208ec0 100644
--- a/dev-util/ccls/ccls-0.20240202.ebuild
+++ b/dev-util/ccls/ccls-0.20240202.ebuild
@@ -33,6 +33,10 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/ccls-0.20240202-gcc15-cstdint.patch
+)
+
src_configure() {
local mycmakeargs=(
-DCCLS_VERSION=${PV}
diff --git a/dev-util/ccls/files/ccls-0.20240202-gcc15-cstdint.patch b/dev-util/ccls/files/ccls-0.20240202-gcc15-cstdint.patch
new file mode 100644
index 000000000000..ffc988d38010
--- /dev/null
+++ b/dev-util/ccls/files/ccls-0.20240202-gcc15-cstdint.patch
@@ -0,0 +1,22 @@
+https://github.com/MaskRay/ccls/pull/968
+
+From dcb10d17de5aa9d2fb2278ea87e76d042d9fda77 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 6 Aug 2024 11:41:47 +0100
+Subject: [PATCH] utils: Add `<cstdint>`
+
+utils uses `uint64_t` without including `<cstdint>`
+which fails to build w/ GCC 15 after a change in libstdc++ [0]
+
+[0] https://gcc.gnu.org/git/?p=gcc.git;a=commit;h=3a817a4a5a6d94da9127af3be9f84a74e3076ee2
+--- a/src/utils.hh
++++ b/src/utils.hh
+@@ -6,6 +6,7 @@
+ #include <optional>
+ #include <string_view>
+
++#include <cstdint>
+ #include <iterator>
+ #include <memory>
+ #include <string>
+