summaryrefslogtreecommitdiff
path: root/dev-util/clazy/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/clazy/files')
-rw-r--r--dev-util/clazy/files/clazy-1.10-gcc-build.patch44
-rw-r--r--dev-util/clazy/files/clazy-1.10-llvm-earlier-than-12.patch20
-rw-r--r--dev-util/clazy/files/clazy-1.10-use-c++17.patch20
3 files changed, 0 insertions, 84 deletions
diff --git a/dev-util/clazy/files/clazy-1.10-gcc-build.patch b/dev-util/clazy/files/clazy-1.10-gcc-build.patch
deleted file mode 100644
index 647c254b644d..000000000000
--- a/dev-util/clazy/files/clazy-1.10-gcc-build.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-https://invent.kde.org/sdk/clazy/-/commit/b74c8729b7b71528c1528579435cda7fdb5d31b4
-
-From: Sergio Martins <smartins@kde.org>
-Date: Thu, 2 Dec 2021 11:05:51 +0000
-Subject: [PATCH] Fix build with some newer gcc complaining about deleted Lexer
-
---- a/src/SourceCompatibilityHelpers.h
-+++ b/src/SourceCompatibilityHelpers.h
-@@ -117,17 +117,13 @@ inline auto getBuffer(const clang::SourceManager &sm, clang::FileID id, bool *in
- }
-
- #if LLVM_VERSION_MAJOR >= 12
--inline clang::Lexer getLexer(clang::FileID id, llvm::Optional<llvm::MemoryBufferRef> inputFile,
-- const clang::SourceManager &sm, const clang::LangOptions &lo)
--{
-- return clang::Lexer(id, inputFile.getValue(), sm, lo);
--}
-+
-+#define GET_LEXER(id, inputFile, sm, lo) \
-+clang::Lexer(id, inputFile.getValue(), sm, lo)
-+
- #else
--inline clang::Lexer getLexer(clang::FileID id, const llvm::MemoryBuffer *inputFile,
-- const clang::SourceManager &sm, const clang::LangOptions &lo)
--{
-- return clang::Lexer(id, inputFile, sm, lo);
--}
-+#define GET_LEXER(id, inputFile, sm, lo) \
-+clang::Lexer(id, inputFile.getValue(), sm, lo)
- #endif
-
- inline bool isFinal(const clang::CXXRecordDecl *record)
---- a/src/SuppressionManager.cpp
-+++ b/src/SuppressionManager.cpp
-@@ -91,7 +91,7 @@ void SuppressionManager::parseFile(FileID id, const SourceManager &sm, const cla
- return;
- }
-
-- auto lexer = clazy::getLexer(id, buffer, sm, lo);
-+ auto lexer = GET_LEXER(id, buffer, sm, lo);
- lexer.SetCommentRetentionState(true);
-
- Token token;
-GitLab
diff --git a/dev-util/clazy/files/clazy-1.10-llvm-earlier-than-12.patch b/dev-util/clazy/files/clazy-1.10-llvm-earlier-than-12.patch
deleted file mode 100644
index 714d196b5fd9..000000000000
--- a/dev-util/clazy/files/clazy-1.10-llvm-earlier-than-12.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-https://bugs.gentoo.org/829134
-https://invent.kde.org/sdk/clazy/-/commit/0ee1ed9ff1bd4cf2a49e1232696747f1898e2987.patch
-
-From: Allen Winter <allen.winter@kdab.com>
-Date: Sat, 11 Dec 2021 14:57:52 -0500
-Subject: [PATCH] src/SourceCompatibilityHelpers.h - fix compile with LLVM<12
-
-fix the GET_LEXER macro for LLVM versions less than 12
---- a/src/SourceCompatibilityHelpers.h
-+++ b/src/SourceCompatibilityHelpers.h
-@@ -123,7 +123,7 @@ clang::Lexer(id, inputFile.getValue(), sm, lo)
-
- #else
- #define GET_LEXER(id, inputFile, sm, lo) \
--clang::Lexer(id, inputFile.getValue(), sm, lo)
-+clang::Lexer(id, inputFile, sm, lo)
- #endif
-
- inline bool isFinal(const clang::CXXRecordDecl *record)
-GitLab
diff --git a/dev-util/clazy/files/clazy-1.10-use-c++17.patch b/dev-util/clazy/files/clazy-1.10-use-c++17.patch
deleted file mode 100644
index 73bd52aef0e4..000000000000
--- a/dev-util/clazy/files/clazy-1.10-use-c++17.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-https://invent.kde.org/sdk/clazy/-/commit/b0d831a6716229d18f2677c5d356b37f36d4dfd6
-
-From: Sergio Martins <smartins@kde.org>
-Date: Thu, 2 Dec 2021 11:31:58 +0000
-Subject: [PATCH] cmake: Require c++17
-
-Fixes build with newer compiler which were nagging about not
-finding std::filesystem
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -69,7 +69,7 @@ if(MSVC)
- # disable trigger-happy warnings from Clang/LLVM headers
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /wd4267 /wd4244 /wd4291 /wd4800 /wd4141 /wd4146 /wd4251")
- elseif(CMAKE_COMPILER_IS_GNUCXX OR CMAKE_CXX_COMPILER_ID MATCHES "Clang")
-- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++14 -fno-common -Woverloaded-virtual -Wcast-qual -fno-strict-aliasing -pedantic -Wno-long-long -Wall -W -Wno-unused-parameter -Wwrite-strings -fno-exceptions -fno-rtti")
-+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++17 -fno-common -Woverloaded-virtual -Wcast-qual -fno-strict-aliasing -pedantic -Wno-long-long -Wall -W -Wno-unused-parameter -Wwrite-strings -fno-exceptions -fno-rtti")
- endif()
-
- set(CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,-flat_namespace -Wl,-undefined -Wl,suppress")
-GitLab