summaryrefslogtreecommitdiff
path: root/dev-util/cpputest/cpputest-3.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cpputest/cpputest-3.8.ebuild')
-rw-r--r--dev-util/cpputest/cpputest-3.8.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-util/cpputest/cpputest-3.8.ebuild b/dev-util/cpputest/cpputest-3.8.ebuild
new file mode 100644
index 000000000000..af20f1f08b02
--- /dev/null
+++ b/dev-util/cpputest/cpputest-3.8.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="unit testing and mocking framework for C/C++"
+HOMEPAGE="https://cpputest.github.io/ https://github.com/cpputest/cpputest"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="
+ test? ( >=dev-cpp/gtest-1.8.0 )
+"
+
+DOCS=( AUTHORS README.md README_CppUTest_for_C.txt )