summaryrefslogtreecommitdiff
path: root/dev-util/ddd/ddd-3.3.12-r5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ddd/ddd-3.3.12-r5.ebuild')
-rw-r--r--dev-util/ddd/ddd-3.3.12-r5.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/dev-util/ddd/ddd-3.3.12-r5.ebuild b/dev-util/ddd/ddd-3.3.12-r5.ebuild
index fe17fd18d911..0174afbfd0e7 100644
--- a/dev-util/ddd/ddd-3.3.12-r5.ebuild
+++ b/dev-util/ddd/ddd-3.3.12-r5.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
inherit autotools desktop optfeature
@@ -10,10 +10,12 @@ HOMEPAGE="https://www.gnu.org/software/ddd"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-3 LGPL-3 FDL-1.1"
-KEYWORDS="~alpha amd64 ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
SLOT="0"
+KEYWORDS="~alpha amd64 ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
IUSE="readline"
+RESTRICT="test"
+
COMMON_DEPEND="
sys-devel/gdb
sys-libs/ncurses:=
@@ -34,8 +36,6 @@ RDEPEND="${COMMON_DEPEND}
x11-apps/xfontsel
"
-RESTRICT="test"
-
PATCHES=(
"${FILESDIR}/${P}-gcc44.patch"
"${FILESDIR}/${P}-gdb-disassembler-bug.patch"
@@ -58,13 +58,12 @@ src_prepare() {
src_configure() {
econf \
- --disable-static \
$(use_with readline)
}
src_install() {
# Remove app defaults
- rm -f "${S}"/ddd/Ddd
+ rm -f "${S}"/ddd/Ddd || die
# Install ddd distribution
default
@@ -79,10 +78,8 @@ pkg_postinst() {
optfeature "Bash debugging" app-shells/bashdb
optfeature "Perl debugging" dev-lang/perl
optfeature "Python debugging" dev-python/pydb
-
- echo
+ elog
elog "Important notice: if you encounter DDD crashes during visualization, you might"
elog "have hit bug #459324. Try switching to plotting in external window:"
elog "Select Edit|Preferences|Helpers and switch 'plot window' to 'external'"
- echo
}