summaryrefslogtreecommitdiff
path: root/dev-util/diff-cover/diff-cover-6.5.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/diff-cover/diff-cover-6.5.0-r1.ebuild')
-rw-r--r--dev-util/diff-cover/diff-cover-6.5.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/diff-cover/diff-cover-6.5.0-r1.ebuild b/dev-util/diff-cover/diff-cover-6.5.0-r1.ebuild
new file mode 100644
index 000000000000..670609c2faec
--- /dev/null
+++ b/dev-util/diff-cover/diff-cover-6.5.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Find diff lines that do not have test coverage"
+HOMEPAGE="https://github.com/Bachmann1234/diff-cover"
+SRC_URI="https://github.com/Bachmann1234/diff-cover/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P/diff-cover/diff_cover}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7.1[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-0.13.1[${PYTHON_USEDEP}]
+ >=dev-python/chardet-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.2.1
+ "
+ BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest